aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-ming/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-10-17 17:04:40 +0800
committerknu <knu@FreeBSD.org>2000-10-17 17:04:40 +0800
commit819646bfc081be2e8a97ece1f376efacff9fd762 (patch)
treee45d5e4b6d3c6bcc494f1762e098abbd88e26d61 /graphics/py-ming/Makefile
parent27133eb33b182369fe2d176019826f6d8182f25c (diff)
downloadfreebsd-ports-gnome-819646bfc081be2e8a97ece1f376efacff9fd762.tar.gz
freebsd-ports-gnome-819646bfc081be2e8a97ece1f376efacff9fd762.tar.zst
freebsd-ports-gnome-819646bfc081be2e8a97ece1f376efacff9fd762.zip
Respect CC and CFLAGS.
Define and use SWIG instead of hardcoding swig's executable name in a patch. Remove the "chmod 755 xxx.so" line from the distributed Makefile.
Diffstat (limited to 'graphics/py-ming/Makefile')
-rw-r--r--graphics/py-ming/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/graphics/py-ming/Makefile b/graphics/py-ming/Makefile
index c774aee1cdc5..0629866e0b01 100644
--- a/graphics/py-ming/Makefile
+++ b/graphics/py-ming/Makefile
@@ -14,7 +14,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= knu@FreeBSD.org
-BUILD_DEPENDS= swig1.3:${PORTSDIR}/devel/SWIG-devel
+BUILD_DEPENDS= ${SWIG}:${PORTSDIR}/devel/SWIG-devel
LIB_DEPENDS= ming.0:${PORTSDIR}/graphics/ming
USE_PYTHON= yes
@@ -22,7 +22,9 @@ USE_PYTHON= yes
MD5_FILE= ${PORTSDIR}/graphics/ming/distinfo
WRKSRC= ${WRKDIR}/${DISTNAME}/py_ext
-MAKE_ARGS= PYTHON_VERSION="${PYTHON_VERSION}"
+MAKE_ARGS= PYTHON_VERSION="${PYTHON_VERSION}" SWIG="${SWIG}"
+
+SWIG= swig1.3
EXAMPLES= shape.py test.py