aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-ming
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2016-04-15 00:38:39 +0800
committersunpoet <sunpoet@FreeBSD.org>2016-04-15 00:38:39 +0800
commit80905d7456edae6b1d2ba51732dd04375dfe275d (patch)
tree00ebbe34a9db1d11def78360193846d56209389f /graphics/py-ming
parent0c5d5a3143089636c782d194617c65a6bc6a9c23 (diff)
downloadfreebsd-ports-gnome-80905d7456edae6b1d2ba51732dd04375dfe275d.tar.gz
freebsd-ports-gnome-80905d7456edae6b1d2ba51732dd04375dfe275d.tar.zst
freebsd-ports-gnome-80905d7456edae6b1d2ba51732dd04375dfe275d.zip
- Use default WRKSRC
Diffstat (limited to 'graphics/py-ming')
-rw-r--r--graphics/py-ming/Makefile15
-rw-r--r--graphics/py-ming/files/patch-macros-python.m44
-rw-r--r--graphics/py-ming/files/patch-py_ext-ming.py (renamed from graphics/py-ming/files/patch-ming.py)4
3 files changed, 11 insertions, 12 deletions
diff --git a/graphics/py-ming/Makefile b/graphics/py-ming/Makefile
index 510b63e2f477..117609ad8fd5 100644
--- a/graphics/py-ming/Makefile
+++ b/graphics/py-ming/Makefile
@@ -13,8 +13,8 @@ COMMENT= Python module for Ming which allows you to create Flash 4/5 movies
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
-LICENSE_FILE_GPLv2= ${WRKSRC}/../LICENSE_GPL2
-LICENSE_FILE_LGPL21= ${WRKSRC}/../LICENSE
+LICENSE_FILE_GPLv2= ${WRKSRC}/LICENSE_GPL2
+LICENSE_FILE_LGPL21= ${WRKSRC}/LICENSE
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libgif.so:graphics/giflib \
@@ -29,18 +29,17 @@ GNU_CONFIGURE= yes
USE_PYTHON= autoplist concurrent distutils
USES= autoreconf libtool localbase python
-AUTORECONF_WRKSRC= ${CONFIGURE_WRKSRC}
-CONFIGURE_WRKSRC= ${WRKDIR}/${GH_PROJECT}-${GH_TAGNAME_EXTRACT}
-WRKSRC= ${WRKDIR}/${GH_PROJECT}-${GH_TAGNAME_EXTRACT}/py_ext
+BUILD_WRKSRC= ${WRKSRC}/py_ext
+INSTALL_WRKSRC= ${WRKSRC}/py_ext
USE_GITHUB= yes
GH_ACCOUNT= lib${PORTNAME}
GH_PROJECT= lib${PORTNAME}
post-patch:
- @${REINPLACE_CMD} -e 's| --root ".*"||' ${WRKSRC}/Makefile.am
- @${REINPLACE_CMD} -e 's|/usr/local/|${LOCALBASE}/|g' ${WRKSRC}/setup.py.in
- @${LN} -fs ${LOCALBASE}/include/ming ${WRKSRC}/../src
+ @${REINPLACE_CMD} -e 's| --root ".*"||' ${WRKSRC}/py_ext/Makefile.am
+ @${REINPLACE_CMD} -e 's|/usr/local/|${LOCALBASE}/|g' ${WRKSRC}/py_ext/setup.py.in
+ @${LN} -fs ${LOCALBASE}/include/ming ${WRKSRC}/src
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/_mingc.so
diff --git a/graphics/py-ming/files/patch-macros-python.m4 b/graphics/py-ming/files/patch-macros-python.m4
index a309ade89cff..5ace1bf6b464 100644
--- a/graphics/py-ming/files/patch-macros-python.m4
+++ b/graphics/py-ming/files/patch-macros-python.m4
@@ -1,5 +1,5 @@
---- ../macros/python.m4.orig 2015-05-15 09:43:14 UTC
-+++ ../macros/python.m4
+--- macros/python.m4.orig 2015-05-15 09:43:14 UTC
++++ macros/python.m4
@@ -94,8 +94,8 @@ AC_DEFUN([AC_PYTHON_DEVEL],[
#
AC_MSG_CHECKING([for a version of Python >= '2.1.0'])
diff --git a/graphics/py-ming/files/patch-ming.py b/graphics/py-ming/files/patch-py_ext-ming.py
index a1fcf3a214a9..ffc31927011a 100644
--- a/graphics/py-ming/files/patch-ming.py
+++ b/graphics/py-ming/files/patch-py_ext-ming.py
@@ -1,5 +1,5 @@
---- ming.py.orig 2015-05-15 09:43:14 UTC
-+++ ming.py
+--- py_ext/ming.py.orig 2015-05-15 09:43:14 UTC
++++ py_ext/ming.py
@@ -112,57 +112,57 @@ class SWFFilter(SWFBase):
if type == SWFFILTER_TYPE_DROPSHADOW:
#color, blur, shadow, flags