aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-nwdiag/Makefile
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2011-08-07 14:02:49 +0800
committertota <tota@FreeBSD.org>2011-08-07 14:02:49 +0800
commit895da91915eaeda6f08c8ff387222dc1f0d3f99e (patch)
treef99cfc72328898182ec65834901763124f0d003f /graphics/py-nwdiag/Makefile
parentd50e4bbe36977ef7e79a407ed7b6c0f9c34275b7 (diff)
downloadfreebsd-ports-gnome-895da91915eaeda6f08c8ff387222dc1f0d3f99e.tar.gz
freebsd-ports-gnome-895da91915eaeda6f08c8ff387222dc1f0d3f99e.tar.zst
freebsd-ports-gnome-895da91915eaeda6f08c8ff387222dc1f0d3f99e.zip
- Add a new port: graphics/py-nwdiag
`nwdiag` generate network-diagram image file from spec-text file. Features * Generate network-diagram from dot like text (basic feature). * Multilingualization for node-label (utf-8 only). WWW: http://blockdiag.com/nwdiag/build/html/
Diffstat (limited to 'graphics/py-nwdiag/Makefile')
-rw-r--r--graphics/py-nwdiag/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/graphics/py-nwdiag/Makefile b/graphics/py-nwdiag/Makefile
new file mode 100644
index 000000000000..0a44df81fd70
--- /dev/null
+++ b/graphics/py-nwdiag/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: py-nwdiag
+# Date created: 2011-08-07
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nwdiag
+PORTVERSION= 0.3.3
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= A simple network-diagram image generator
+
+LICENSE= ASL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PKGNAMEPREFIX}imaging>=1.1.5:${PORTSDIR}/graphics/py-imaging \
+ ${PKGNAMEPREFIX}funcparserlib>=0.3.4:${PORTSDIR}/devel/py-funcparserlib \
+ ${PKGNAMEPREFIX}blockdiag>=0.8.7:${PORTSDIR}/graphics/py-blockdiag
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+
+PORTDOCS= README.txt
+PORTEXAMPLES= *
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${INSTALL_WRKSRC}/src/${PORTDOCS} ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${INSTALL_WRKSRC}/examples/${PORTEXAMPLES} ${EXAMPLESDIR}
+.endif
+
+x-generate-plist:
+ ${ECHO} bin/${PORTNAME} > pkg-plist.new
+ ${FIND} ${PYTHON_SITELIBDIR}/${PYEASYINSTALL_EGG} -type f | ${SORT} | \
+ ${SED} -e 's,${PYTHON_SITELIBDIR},%%PYTHON_SITELIBDIR%%,' \
+ -e 's,${PYEASYINSTALL_EGG},%%PYEASYINSTALL_EGG%%,' \
+ >> pkg-plist.new
+ ${FIND} ${PYTHON_SITELIBDIR}/${PYEASYINSTALL_EGG} -type d -depth | ${SORT} -r | \
+ ${SED} -e 's,${PYTHON_SITELIBDIR},@dirrm %%PYTHON_SITELIBDIR%%,' \
+ -e 's,${PYEASYINSTALL_EGG},%%PYEASYINSTALL_EGG%%,' \
+ >> pkg-plist.new
+
+.include <bsd.port.mk>