aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-pycollada
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2017-02-25 01:16:31 +0800
committerkrion <krion@FreeBSD.org>2017-02-25 01:16:31 +0800
commit91907aacc085a18cc963915f2a454e66e5d37a17 (patch)
treecfd8b849ebf77bc07772dffa828bae13d0ad316e /graphics/py-pycollada
parent4d1c12b0aa80aa2497bbe6eb568cd7aa6358040f (diff)
downloadfreebsd-ports-gnome-91907aacc085a18cc963915f2a454e66e5d37a17.tar.gz
freebsd-ports-gnome-91907aacc085a18cc963915f2a454e66e5d37a17.tar.zst
freebsd-ports-gnome-91907aacc085a18cc963915f2a454e66e5d37a17.zip
New port: graphics/py-pycollada
Pycollada is a python module for creating, editing and loading COLLADA, which is a COLLAborative Design Activity for establishing an interchange file format for interactive 3D applications. WWW: http://pycollada.readthedocs.org/ PR: 214318 Submitted by: tj+freebsd_bugs@a13.fr Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D9775
Diffstat (limited to 'graphics/py-pycollada')
-rw-r--r--graphics/py-pycollada/Makefile26
-rw-r--r--graphics/py-pycollada/distinfo3
-rw-r--r--graphics/py-pycollada/pkg-descr5
3 files changed, 34 insertions, 0 deletions
diff --git a/graphics/py-pycollada/Makefile b/graphics/py-pycollada/Makefile
new file mode 100644
index 000000000000..00f5df23d546
--- /dev/null
+++ b/graphics/py-pycollada/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= pycollada
+PORTVERSION= 0.4.1
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= tj+freebsd_ports@a13.fr
+COMMENT= Python library for reading and writing collada documents
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>0:math/py-numpy \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=2.0:devel/py-dateutil
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist distutils
+
+OPTIONS_DEFINE= LXML
+
+LXML_DESC= Uses lxml for XML loading, construction, and saving.
+LXML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml
+
+.include <bsd.port.mk>
diff --git a/graphics/py-pycollada/distinfo b/graphics/py-pycollada/distinfo
new file mode 100644
index 000000000000..675477a76306
--- /dev/null
+++ b/graphics/py-pycollada/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1478552877
+SHA256 (pycollada-0.4.1.tar.gz) = 9b7aba2af93adbe207dab48b427902f56afd717cf9bf5f52e617948212a4a044
+SIZE (pycollada-0.4.1.tar.gz) = 110434
diff --git a/graphics/py-pycollada/pkg-descr b/graphics/py-pycollada/pkg-descr
new file mode 100644
index 000000000000..17085da55072
--- /dev/null
+++ b/graphics/py-pycollada/pkg-descr
@@ -0,0 +1,5 @@
+Pycollada is a python module for creating, editing and loading COLLADA, which
+is a COLLAborative Design Activity for establishing an interchange file format
+for interactive 3D applications.
+
+WWW: http://pycollada.readthedocs.org/