aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-pyggel
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-04-07 09:02:29 +0800
committernemysis <nemysis@FreeBSD.org>2014-04-07 09:02:29 +0800
commitd16d4c50319afe7ac144df734fae4dc23ce98ca8 (patch)
treeb34cc1e3359e3eba7d9b4dd36be1b92e65e88273 /graphics/py-pyggel
parentc68e99f53bccd024e953bebf66468f7f2a27ec4c (diff)
downloadfreebsd-ports-gnome-d16d4c50319afe7ac144df734fae4dc23ce98ca8.tar.gz
freebsd-ports-gnome-d16d4c50319afe7ac144df734fae4dc23ce98ca8.tar.zst
freebsd-ports-gnome-d16d4c50319afe7ac144df734fae4dc23ce98ca8.zip
- Rename from graphics/pyggel to graphics/py-pyggel
- Add PKGNAMEPREFIX=${PYTHON_PKGNAMEPREFIX}
Diffstat (limited to 'graphics/py-pyggel')
-rw-r--r--graphics/py-pyggel/Makefile58
-rw-r--r--graphics/py-pyggel/distinfo2
-rw-r--r--graphics/py-pyggel/pkg-descr5
3 files changed, 65 insertions, 0 deletions
diff --git a/graphics/py-pyggel/Makefile b/graphics/py-pyggel/Makefile
new file mode 100644
index 000000000000..fe7441f3e743
--- /dev/null
+++ b/graphics/py-pyggel/Makefile
@@ -0,0 +1,58 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pyggel
+PORTVERSION= 0.08
+DISTVERSIONSUFFIX= -alpha4c
+CATEGORIES= graphics python
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= ${PORTNAME:U}-V${DISTVERSION}${DISTVERSIONSUFFIX}
+DIST_SUBDIR= python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Python Graphical Game Engine and Libraries
+
+LICENSE= LGPL3 Public_Domain
+LICENSE_COMB= dual
+LICENSE_NAME_Public_Domain= Public Domain
+LICENSE_TEXT_Public_Domain= Public Domain
+LICENSE_PERMS_Public_Domain=dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYGAME} \
+ ${PYTHON_PKGNAMEPREFIX}opengl>=0:${PORTSDIR}/graphics/py-opengl \
+ ${PYTHON_PKGNAMEPREFIX}imaging>=0:${PORTSDIR}/graphics/py-imaging
+
+USES= dos2unix zip
+DOS2UNIX_GLOB= *.mtl *.py *.txt
+USE_PYTHON= 2
+NO_BUILD= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_AUTOPLIST= yes
+
+PORTDOCS= Readme.txt
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|data_files =|#data_files =|' \
+ ${WRKSRC}/setup.py
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @(cd ${WRKSRC}/examples_and_tutorials && ${COPYTREE_SHARE} . \
+ ${STAGEDIR}${EXAMPLESDIR}/examples_and_tutorials)
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} data ${STAGEDIR}${EXAMPLESDIR})
+. for f in test_FBO test_camera test_gui test_mesh test_particle test_texture_swap
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${f}.py ${STAGEDIR}${EXAMPLESDIR})
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/py-pyggel/distinfo b/graphics/py-pyggel/distinfo
new file mode 100644
index 000000000000..845452212b57
--- /dev/null
+++ b/graphics/py-pyggel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python/PYGGEL-V0.08-alpha4c.zip) = 492bafd20a8cb1af2de4c5142875371a5d6dd3f1223959b169c15b6196bbca92
+SIZE (python/PYGGEL-V0.08-alpha4c.zip) = 438750
diff --git a/graphics/py-pyggel/pkg-descr b/graphics/py-pyggel/pkg-descr
new file mode 100644
index 000000000000..08342d9c4593
--- /dev/null
+++ b/graphics/py-pyggel/pkg-descr
@@ -0,0 +1,5 @@
+Pyggel (Python Graphical Game Engine + Libraries) will ease the learning curve
+of getting into 3d programming, while also having a strong enough framework
+for full-sized applications.
+
+WWW: https://code.google.com/p/pyggel/