aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-pygooglechart
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2009-01-10 01:53:24 +0800
committernivit <nivit@FreeBSD.org>2009-01-10 01:53:24 +0800
commita2598acfad1489e6e235f8c9222f6a3ac40724f7 (patch)
treed2e93ae7eba90d582522fcf8a3637f423e15a28d /graphics/py-pygooglechart
parenteb51adfa25897b359d1ea1f900213a1fdfcdb25f (diff)
downloadfreebsd-ports-gnome-a2598acfad1489e6e235f8c9222f6a3ac40724f7.tar.gz
freebsd-ports-gnome-a2598acfad1489e6e235f8c9222f6a3ac40724f7.tar.zst
freebsd-ports-gnome-a2598acfad1489e6e235f8c9222f6a3ac40724f7.zip
A complete Python wrapper for the Google Chart API
WWW: http://pygooglechart.slowchop.com/
Diffstat (limited to 'graphics/py-pygooglechart')
-rw-r--r--graphics/py-pygooglechart/Makefile32
-rw-r--r--graphics/py-pygooglechart/distinfo3
-rw-r--r--graphics/py-pygooglechart/pkg-descr3
3 files changed, 38 insertions, 0 deletions
diff --git a/graphics/py-pygooglechart/Makefile b/graphics/py-pygooglechart/Makefile
new file mode 100644
index 000000000000..0681adecbdeb
--- /dev/null
+++ b/graphics/py-pygooglechart/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: pygooglechart
+# Date created: 2009-01-09
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pygooglechart
+PORTVERSION= 0.2.1
+#PORTREVISION= 0
+CATEGORIES= graphics python
+MASTER_SITES= http://pygooglechart.slowchop.com/files/download/ \
+ LOCAL/nivit/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= A complete Python wrapper for the Google Chart API
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+PORTEXAMPLES= *
+
+.if !defined(NOPORTEXAMPLES)
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+post-install:
+ ${MKDIR} ${EXAMPLESDIR} && cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/py-pygooglechart/distinfo b/graphics/py-pygooglechart/distinfo
new file mode 100644
index 000000000000..7e70ed1844af
--- /dev/null
+++ b/graphics/py-pygooglechart/distinfo
@@ -0,0 +1,3 @@
+MD5 (pygooglechart-0.2.1.tar.gz) = ec6e1ddd678485c7971c8c0b5dd3cec6
+SHA256 (pygooglechart-0.2.1.tar.gz) = 0748c77e6a9f8b59f8b15f323b13b5856fb51bb42fa21e448d8ca2da6a228f39
+SIZE (pygooglechart-0.2.1.tar.gz) = 25078
diff --git a/graphics/py-pygooglechart/pkg-descr b/graphics/py-pygooglechart/pkg-descr
new file mode 100644
index 000000000000..2c4327e1534b
--- /dev/null
+++ b/graphics/py-pygooglechart/pkg-descr
@@ -0,0 +1,3 @@
+A complete Python wrapper for the Google Chart API
+
+WWW: http://pygooglechart.slowchop.com/