aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-soya3d
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2006-09-20 19:21:59 +0800
committerstas <stas@FreeBSD.org>2006-09-20 19:21:59 +0800
commit690719e4d56669840ac4b9264f949634ed10d1c1 (patch)
treef8a62d437d458241263339bd8d7a8582056207da /graphics/py-soya3d
parent5cbdf409c7db9b9d115b500f9084c97595f61719 (diff)
downloadfreebsd-ports-gnome-690719e4d56669840ac4b9264f949634ed10d1c1.tar.gz
freebsd-ports-gnome-690719e4d56669840ac4b9264f949634ed10d1c1.tar.zst
freebsd-ports-gnome-690719e4d56669840ac4b9264f949634ed10d1c1.zip
- Update devel/sdl12 to version 1.2.11. Now we employ stock SDL directory
structure (i.e. include/SDL for includes and sdl-config for configuration binary) - Update graphics/sdl_ttf to version 2.0.8 - Update graphics/sdl_image to version 1.2.5 - Update audio/sdl_mixer to version 1.2.7 - Update net/sdl_net to version 1.2.6 - Update Mk/bsd.sdl.mk accordingly - Fix dependent ports to fit the new directory structure and avoid several API breakages - Bump up portrevisions for all dependent ports to allow them to be upgraded by portupgrade/portmaster etc tools Approved by: kris (portmgr), sem (mentor)
Diffstat (limited to 'graphics/py-soya3d')
-rw-r--r--graphics/py-soya3d/Makefile2
-rw-r--r--graphics/py-soya3d/files/patch-setup.py17
2 files changed, 0 insertions, 19 deletions
diff --git a/graphics/py-soya3d/Makefile b/graphics/py-soya3d/Makefile
index 7672ceed7fd0..7828b35cd347 100644
--- a/graphics/py-soya3d/Makefile
+++ b/graphics/py-soya3d/Makefile
@@ -55,8 +55,6 @@ STDINTFLAG= true
.endif
post-patch:
- @cd ${WRKSRC} && \
- ${FIND} * -type f -exec ${REINPLACE_CMD} -i "" -e 's|SDL/|SDL11/|g' "{}" \;
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-e 's|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/setup.py
@${REINPLACE_CMD} -e \
diff --git a/graphics/py-soya3d/files/patch-setup.py b/graphics/py-soya3d/files/patch-setup.py
index 70e12375091a..a7dff9ece576 100644
--- a/graphics/py-soya3d/files/patch-setup.py
+++ b/graphics/py-soya3d/files/patch-setup.py
@@ -1,22 +1,5 @@
--- setup.py Mon Aug 21 00:22:53 2006
+++ setup.py Mon Aug 21 00:24:52 2006
-@@ -37,6 +37,7 @@
- "/usr/include/freetype2",
- "/usr/local/include/freetype2",
- "/usr/include/cal3d",
-+ "/usr/local/include/SDL11",
- "/usr/local/include/cal3d",
- "/sw/include", # For Mac OS X "fink"
- "/opt/local/include", # For Mac OS X "darwin port"
-@@ -80,7 +81,7 @@
- LIBS = ["m", "glew32", "SDL", "freetype", "cal3d", "stdc++"]
- else:
- #LIBS = ["m", "GLEW", "GL", "GLU", "SDL", "SDL_mixer", "freetype", "cal3d", "stdc++"]
-- LIBS = ["m", "GLEW", "SDL", "freetype", "cal3d", "stdc++"]
-+ LIBS = ["m", "GLEW", "SDL-1.1", "freetype", "cal3d", "stdc++"]
-
- SOYA_PYREX_SOURCES = ["_soya.pyx", "matrix.c", "chunk.c" ]
- SOYA_C_SOURCES = ["_soya.c" , "matrix.c", "chunk.c" ]
@@ -99,6 +100,7 @@
if USE_OPENAL:
print "Sound support (with OpenAL) enabled..."