aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-toyplot
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2015-07-16 03:24:51 +0800
committerskreuzer <skreuzer@FreeBSD.org>2015-07-16 03:24:51 +0800
commitf9297b5feb0d7f4ee3119c88b44c633032c0e50a (patch)
tree6de41b51648f82430dcf0eca0b5edfb5b8db35ec /graphics/py-toyplot
parent01035459fd921a18d36b936d41bb5ecb3b037688 (diff)
downloadfreebsd-ports-gnome-f9297b5feb0d7f4ee3119c88b44c633032c0e50a.tar.gz
freebsd-ports-gnome-f9297b5feb0d7f4ee3119c88b44c633032c0e50a.tar.zst
freebsd-ports-gnome-f9297b5feb0d7f4ee3119c88b44c633032c0e50a.zip
Toyplot is a kid-sized plotting toolkit for Python with grownup-sized goals:
* Develop beautiful interactive, animated plots that embrace the unique capabilities of electronic publishing and support repoducibility. * Create the best possible data graphics out-of-the-box, maximizing data ink and minimizing chartjunk. * Provide a clean, minimalist interface that scientists and engineers will love. WWW: https://pypi.python.org/pypi/toyplot
Diffstat (limited to 'graphics/py-toyplot')
-rw-r--r--graphics/py-toyplot/Makefile22
-rw-r--r--graphics/py-toyplot/distinfo2
-rw-r--r--graphics/py-toyplot/pkg-descr10
3 files changed, 34 insertions, 0 deletions
diff --git a/graphics/py-toyplot/Makefile b/graphics/py-toyplot/Makefile
new file mode 100644
index 000000000000..148b59ae0314
--- /dev/null
+++ b/graphics/py-toyplot/Makefile
@@ -0,0 +1,22 @@
+# Created by: Steven Kreuzer <skreuzer@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= toyplot
+PORTVERSION= 0.6.0
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Modern plotting toolkit supporting electronic publishing
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.7:${PORTSDIR}/math/py-numpy \
+ ${PYTHON_PKGNAMEPREFIX}colormath>=2.1.1:${PORTSDIR}/math/py-colormath \
+ ${PYTHON_PKGNAMEPREFIX}multipledispatch>=0.4.7:${PORTSDIR}/devel/py-multipledispatch
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/graphics/py-toyplot/distinfo b/graphics/py-toyplot/distinfo
new file mode 100644
index 000000000000..223aa5db3024
--- /dev/null
+++ b/graphics/py-toyplot/distinfo
@@ -0,0 +1,2 @@
+SHA256 (toyplot-0.6.0.tar.gz) = e7e562f9c202c84d52f9be9f23568f9938f8e0334e15637c964e14f7f82bf6f9
+SIZE (toyplot-0.6.0.tar.gz) = 68113
diff --git a/graphics/py-toyplot/pkg-descr b/graphics/py-toyplot/pkg-descr
new file mode 100644
index 000000000000..e278ee8527f9
--- /dev/null
+++ b/graphics/py-toyplot/pkg-descr
@@ -0,0 +1,10 @@
+Toyplot is a kid-sized plotting toolkit for Python with grownup-sized goals:
+
+* Develop beautiful interactive, animated plots that embrace the unique
+ capabilities of electronic publishing and support repoducibility.
+* Create the best possible data graphics out-of-the-box, maximizing data ink
+ and minimizing chartjunk.
+* Provide a clean, minimalist interface that scientists and engineers will
+ love.
+
+WWW: https://pypi.python.org/pypi/toyplot