aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/qcomicbook/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-12-15 00:50:53 +0800
committermiwi <miwi@FreeBSD.org>2007-12-15 00:50:53 +0800
commit7971e1b199cc75cb27288e571f17048d8998feab (patch)
tree075b84fbc09b48c6fa95b34e2ba1e822ea8cf26f /graphics/qcomicbook/Makefile
parente8beb28c599379be929fb80fee08cddebcd66a70 (diff)
downloadfreebsd-ports-gnome-7971e1b199cc75cb27288e571f17048d8998feab.tar.gz
freebsd-ports-gnome-7971e1b199cc75cb27288e571f17048d8998feab.tar.zst
freebsd-ports-gnome-7971e1b199cc75cb27288e571f17048d8998feab.zip
- Update to 0.4.0
PR: 118621 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'graphics/qcomicbook/Makefile')
-rw-r--r--graphics/qcomicbook/Makefile22
1 files changed, 10 insertions, 12 deletions
diff --git a/graphics/qcomicbook/Makefile b/graphics/qcomicbook/Makefile
index 484d47554f2f..75cf89c668cc 100644
--- a/graphics/qcomicbook/Makefile
+++ b/graphics/qcomicbook/Makefile
@@ -6,30 +6,28 @@
#
PORTNAME= qcomicbook
-PORTVERSION= 0.3.4
-PORTREVISION= 2
+PORTVERSION= 0.4.0
CATEGORIES= graphics
-MASTER_SITES= http://linux.bydg.org/~yogin/
+MASTER_SITES= http://linux.bydg.org/~yogin/qcomicbook/
MAINTAINER= ports@FreeBSD.org
COMMENT= QT-based comic book archive viewer
-LIB_DEPENDS= Imlib2.4:${PORTSDIR}/graphics/imlib2
RUN_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
unrar:${PORTSDIR}/archivers/unrar
-USE_X_PREFIX= yes
-USE_QT_VER= 3
+USE_QT_VER= 4
+QT_COMPONENTS= gui moc
+USE_GNOME= gnometarget
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-Qt-dir="${QT_PREFIX}"
+CONFIGURE_ENV= QtGui_CFLAGS="${QtGui_CFLAGS}"
MAN1= qcomicbook.1
-# Luckily, QT apps on FreeBSD don't compile against
-# pthread by default. That might *gasp* make them work!
-QTCPPFLAGS+= ${PTHREAD_CFLAGS}
-QTCFGLIBS+= ${PTHREAD_LIBS}
+QtGui_CFLAGS= -DQT_SHARED \
+ -I${QT_PREFIX}/include/QtGui \
+ -I${QT_PREFIX}/include/QtCore \
+ -I${QT_PREFIX}/include
.include <bsd.port.mk>