aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/qgis
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-12-03 04:02:26 +0800
committermakc <makc@FreeBSD.org>2010-12-03 04:02:26 +0800
commitb415439f61ca7e8f035bf5f21e9f8f12d97a6a39 (patch)
tree3cac7022b753003610ef59364a3688c7aee5c616 /graphics/qgis
parenta419a2355158dc6e9867b905a32a1594fc1f753f (diff)
downloadfreebsd-ports-gnome-b415439f61ca7e8f035bf5f21e9f8f12d97a6a39.tar.gz
freebsd-ports-gnome-b415439f61ca7e8f035bf5f21e9f8f12d97a6a39.tar.zst
freebsd-ports-gnome-b415439f61ca7e8f035bf5f21e9f8f12d97a6a39.zip
Disable Python support, it's broken with new PyQt4
PR: ports/152754 Approved by: portmgr (miwi)
Diffstat (limited to 'graphics/qgis')
-rw-r--r--graphics/qgis/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index 5a8fce3a2c87..a7a52eed0556 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qgis
PORTVERSION= 1.5.0
+PORTREVISION= 1
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/qgis/src/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -36,7 +37,7 @@ USE_LDCONFIG= yes
OPTIONS= GRASS "Enable GRASS support" Off \
POSTGIS "Enable PostGIS support" Off \
- PYTHON "Enable Python (broken with sip-4.10)" On
+ PYTHON "Enable Python (broken with sip-4.11)" Off
.include <bsd.port.pre.mk>
@@ -65,6 +66,7 @@ PLIST_SUB+= PGSQL="@comment "
.if defined(WITHOUT_PYTHON)
PLIST_SUB+= QGIS_PYTHON="@comment "
.else
+BROKEN= does not compile with sip-4.11
PLIST_SUB+= QGIS_PYTHON=""
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sip>=4.8.2:${PORTSDIR}/devel/py-sip \
${PYTHON_PKGNAMEPREFIX}qt4-gui>=4.5.4:${PORTSDIR}/x11-toolkits/py-qt4-gui \