aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/qiv/Makefile
diff options
context:
space:
mode:
authorbillf <billf@FreeBSD.org>1998-12-27 11:26:57 +0800
committerbillf <billf@FreeBSD.org>1998-12-27 11:26:57 +0800
commit214060c3d6561b7cb2cdec4252c9197950b841e6 (patch)
treecdd87a445c4783fd7a63b7748a839097fc79bf2b /graphics/qiv/Makefile
parentf6a9012bfb7812cedf07ee339d63a3285b3cc3fb (diff)
downloadfreebsd-ports-gnome-214060c3d6561b7cb2cdec4252c9197950b841e6.tar.gz
freebsd-ports-gnome-214060c3d6561b7cb2cdec4252c9197950b841e6.tar.zst
freebsd-ports-gnome-214060c3d6561b7cb2cdec4252c9197950b841e6.zip
Quick Image Viewer (qiv) is a very small and pretty fast GDK/Imlib image
viewer. It has such nifty features as: zoom, maxpect, scaledown, screensaver, flip, delete, brightness / contrast / gamma correction, and can also be used to set your X11 background. All from a commandline. http://www.klografx.de/index.html
Diffstat (limited to 'graphics/qiv/Makefile')
-rw-r--r--graphics/qiv/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/graphics/qiv/Makefile b/graphics/qiv/Makefile
new file mode 100644
index 000000000000..ee0ed810f9a6
--- /dev/null
+++ b/graphics/qiv/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: qiv
+# Version required: 1.0
+# Date created: 25 December 1998
+# Whom: Bill Fumerola <billf@chc-chimes.com>
+#
+# $Id: $
+#
+
+DISTNAME= qiv-1.0
+CATEGORIES= graphics
+MASTER_SITES= http://www.klografx.de/software/files/ \
+ ftp://ftp.klografx.de/pub/ \
+ http://www.idnet.de/~AdamK/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= billf@FreeBSD.org
+
+LIB_DEPENDS= gtk.1:${PORTSDIR}/x11-toolkits/gtk11
+BUILD_DEPENDS= imlib-config:${PORTSDIR}/graphics/imlib
+
+USE_X_PREFIX= yes
+MAN1= qiv.1
+
+post-patch:
+
+ @ ${MV} ${WRKSRC}/qiv.1 ${WRKSRC}/qiv.1.pre_sed
+ @ ${SED} -e 's#\/usr\/bin#${PREFIX}/bin#g' \
+ ${WRKSRC}/qiv.1.pre_sed > ${WRKSRC}/qiv.1
+
+do-install:
+
+ ${INSTALL_PROGRAM} ${WRKSRC}/qiv ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/qiv.1 ${PREFIX}/man/man1/
+
+.include <bsd.port.mk>