aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/qslim
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /graphics/qslim
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'graphics/qslim')
-rw-r--r--graphics/qslim/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/graphics/qslim/Makefile b/graphics/qslim/Makefile
index 1a41e7574595..73bd97a1dfab 100644
--- a/graphics/qslim/Makefile
+++ b/graphics/qslim/Makefile
@@ -17,20 +17,20 @@ COMMENT= SlimKit Surface Modeling Tools
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
- forms.1:${PORTSDIR}/x11-toolkits/xforms \
- glut.4:${PORTSDIR}/graphics/libglut
+ forms.1:${PORTSDIR}/x11-toolkits/xforms
CONFIGURE_WRKSRC= ${WRKSRC}/mixkit/build
BUILD_WRKSRC= ${WRKSRC}/mixkit/src
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_GL= glut
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
ALL_TARGET= # none
-CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include \
- -I${X11BASE}/include/X11 ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS= -I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/X11 ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CFLAGS+= -DMIX_ANSI_IOSTREAMS -fpermissive