aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/qtutils
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-02-02 20:28:29 +0800
committernork <nork@FreeBSD.org>2003-02-02 20:28:29 +0800
commit085178b2d5c0fc92b7e31100d1102f0f956bb778 (patch)
tree952ea0289b7d7b0b66877a4553f3ccb5446720fe /graphics/qtutils
parentcefeb3a82dae21c2dde69f2435ec0e2ec86f075c (diff)
downloadfreebsd-ports-gnome-085178b2d5c0fc92b7e31100d1102f0f956bb778.tar.gz
freebsd-ports-gnome-085178b2d5c0fc92b7e31100d1102f0f956bb778.tar.zst
freebsd-ports-gnome-085178b2d5c0fc92b7e31100d1102f0f956bb778.zip
o Support CFLAGS properly
o Conditionalize gnugetopt dependencies PR ports/47323 Submitted by: Ports Fury
Diffstat (limited to 'graphics/qtutils')
-rw-r--r--graphics/qtutils/Makefile28
-rw-r--r--graphics/qtutils/files/patch-configure10
2 files changed, 29 insertions, 9 deletions
diff --git a/graphics/qtutils/Makefile b/graphics/qtutils/Makefile
index 61e0d884314c..bb4181607850 100644
--- a/graphics/qtutils/Makefile
+++ b/graphics/qtutils/Makefile
@@ -14,22 +14,32 @@ DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis \
- quicktime:${PORTSDIR}/graphics/libquicktime \
- gnugetopt:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= vorbis.2:${PORTSDIR}/audio/libvorbis \
+ quicktime.0:${PORTSDIR}/graphics/libquicktime
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_REINPLACE= yes
USE_GNOMENG= yes
USE_GNOME= glib12
+USE_REINPLACE= yes
USE_LIBTOOL= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= qtconv.1 qtsg.1 qtsplit.1
+CPPFLAGS= -I${LOCALBASE}/include `${GLIB_CONFIG} --cflags gthread`
+LDFLAGS= -L${LOCALBASE}/lib `${GLIB_CONFIG} --libs gthread`
+
+.if !exists(/usr/include/getopt.h)
+LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LDFLAGS+= -lgnugetopt
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g" \
- -e "s,-lglib,-lglib12,g" -e "s,-ldl,,g" ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|-g -Wall|@CFLAGS@|g ; \
+ s|-lglib||g ; \
+ s|-lpthread||g ; \
+ s|-ldl||g' ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>
diff --git a/graphics/qtutils/files/patch-configure b/graphics/qtutils/files/patch-configure
new file mode 100644
index 000000000000..c77aa73dc0ef
--- /dev/null
+++ b/graphics/qtutils/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Sat Jun 8 19:34:22 2002
++++ configure Sun Sep 15 07:24:00 2002
+@@ -6572,6 +6572,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'