aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/quat-gui
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-08-30 08:27:12 +0800
committerlioux <lioux@FreeBSD.org>2002-08-30 08:27:12 +0800
commit473212bcfdc7157ac90e8032c30d443ea695af09 (patch)
tree9cf935c4014da0dafa1ee56bfd434c0058a25fac /graphics/quat-gui
parentdaea608fc5605a80c4e17181dc38ebee10537e5f (diff)
downloadfreebsd-ports-gnome-473212bcfdc7157ac90e8032c30d443ea695af09.tar.gz
freebsd-ports-gnome-473212bcfdc7157ac90e8032c30d443ea695af09.tar.zst
freebsd-ports-gnome-473212bcfdc7157ac90e8032c30d443ea695af09.zip
New port quat-gui version 1.11: A Three-dimensional fractal creator
(X11 GUI) Submitted by: David Yeske <dyeske@yahoo.com>
Diffstat (limited to 'graphics/quat-gui')
-rw-r--r--graphics/quat-gui/Makefile31
-rw-r--r--graphics/quat-gui/distinfo1
-rw-r--r--graphics/quat-gui/pkg-comment1
-rw-r--r--graphics/quat-gui/pkg-descr15
-rw-r--r--graphics/quat-gui/pkg-plist2
5 files changed, 50 insertions, 0 deletions
diff --git a/graphics/quat-gui/Makefile b/graphics/quat-gui/Makefile
new file mode 100644
index 000000000000..5206ffa6cbb6
--- /dev/null
+++ b/graphics/quat-gui/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: quat-gui
+# Date created: 2 May 2002
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= quat
+PORTVERSION= 1.11
+CATEGORIES= graphics
+MASTER_SITES= http://www.physcip.uni-stuttgart.de/phy11733/download/
+PKGNAMESUFFIX= -gui
+DISTNAME= quat-${PORTVERSION:S/.p/pre/}
+
+MAINTAINER= dyeske@yahoo.com
+
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+
+USE_X_PREFIX= yes
+USE_MESA= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -L${X11BASE}/lib" LIBS="-lXext -lGL"
+
+post-patch:
+ @${REINPLACE_CMD} -E -e 's,-(march=pentium|O3|ffast-math),,g' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -E -e 's|-I\.[[:space:]]+-I\$$\(srcdir\)[[:space:]]+||' \
+ ${WRKSRC}/gui/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/graphics/quat-gui/distinfo b/graphics/quat-gui/distinfo
new file mode 100644
index 000000000000..c8955d1f2427
--- /dev/null
+++ b/graphics/quat-gui/distinfo
@@ -0,0 +1 @@
+MD5 (quat-1.11.tar.gz) = ca8af28299924d32166278aa2ef30333
diff --git a/graphics/quat-gui/pkg-comment b/graphics/quat-gui/pkg-comment
new file mode 100644
index 000000000000..8b835d3cdf55
--- /dev/null
+++ b/graphics/quat-gui/pkg-comment
@@ -0,0 +1 @@
+A Three-dimensional fractal creator (X11 GUI)
diff --git a/graphics/quat-gui/pkg-descr b/graphics/quat-gui/pkg-descr
new file mode 100644
index 000000000000..1890e9843c00
--- /dev/null
+++ b/graphics/quat-gui/pkg-descr
@@ -0,0 +1,15 @@
+Idea and purpose of this program is the calculation of three-dimensional
+fractals. The calculated objects are twisted, freely in space
+floating (and - of course - fractal) "lumps" which look like made
+of dough - in contrast to what is normally called "three-dimensional"
+fractals (namely a simple reinterpretation of the two-dimensional
+data).
+
+Generation of a really three dimensional view is possible (3d
+stereo). The fractal can be seen three dimensional without any
+utilities like 3d glasses.
+
+WWW: http://www.physcip.uni-stuttgart.de/phy11733/
+
+- David
+dyeske@yahoo.com
diff --git a/graphics/quat-gui/pkg-plist b/graphics/quat-gui/pkg-plist
new file mode 100644
index 000000000000..108dc93e754d
--- /dev/null
+++ b/graphics/quat-gui/pkg-plist
@@ -0,0 +1,2 @@
+bin/quat
+lib/libquat.a