aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/raster3d
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-04-28 22:20:45 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-04-28 22:20:45 +0800
commit549f8c71b238886293e500065088f9a8048b5f6a (patch)
treed3926824061dd017e82f63f71982c26b833902b9 /graphics/raster3d
parentffb98eed056a4e0786d4472e510b678cd224a2c6 (diff)
downloadfreebsd-ports-gnome-549f8c71b238886293e500065088f9a8048b5f6a.tar.gz
freebsd-ports-gnome-549f8c71b238886293e500065088f9a8048b5f6a.tar.zst
freebsd-ports-gnome-549f8c71b238886293e500065088f9a8048b5f6a.zip
Add raster3d, a set of tools for generating raster images of proteins
and molecules. PR: 96444 Submitted by: Shaun Amott <shaun@inerd.com>
Diffstat (limited to 'graphics/raster3d')
-rw-r--r--graphics/raster3d/Makefile65
-rw-r--r--graphics/raster3d/distinfo3
-rw-r--r--graphics/raster3d/files/extrapatch-avs2ps.c11
-rw-r--r--graphics/raster3d/files/extrapatch-in.h521
-rw-r--r--graphics/raster3d/files/patch-Makefile19
-rw-r--r--graphics/raster3d/pkg-descr17
-rw-r--r--graphics/raster3d/pkg-plist157
7 files changed, 793 insertions, 0 deletions
diff --git a/graphics/raster3d/Makefile b/graphics/raster3d/Makefile
new file mode 100644
index 000000000000..db2c150eabe9
--- /dev/null
+++ b/graphics/raster3d/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: Raster3D
+# Date Created: 2006-04-28
+# Whom: Shaun Amott <shaun@inerd.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= raster3d
+DISTVERSION= 2.7d
+CATEGORIES= graphics biology
+MASTER_SITES= http://skuld.bmsc.washington.edu/${PORTNAME}/
+DISTNAME= Raster3D_${DISTVERSION}
+
+MAINTAINER= shaun@inerd.com
+COMMENT= A set of tools for generating raster images of proteins and molecules
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
+BINARIES= avs2ps balls rastep render ribbon rings3d rods normal3d
+SCRIPTS= label3d stereo3d
+
+MAKE_ENV+= FFLAGS="${FFLAGS}"
+
+.if !defined(WITHOUT_IMAGEMAGICK)
+RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
+PLIST_SUB+= IMAGEMAGICK=""
+.else
+PLIST_SUB+= IMAGEMAGICK="@comment "
+.endif
+
+MANL= avs2ps.l label3d.l r3d_objects.l rastep.l render.l rods.l \
+ balls.l normal3d.l r3dtops.l raster3d.l ribbon.l stereo3d.l
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-avs2ps.c ${FILESDIR}/extrapatch-in.h
+.endif
+
+pre-build:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} freebsd
+
+do-install:
+ cd ${WRKSRC} && ${INSTALL_PROGRAM} ${BINARIES} ${PREFIX}/bin
+.if !defined(WITHOUT_IMAGEMAGICK)
+ cd ${WRKSRC} && ${INSTALL_SCRIPT} ${SCRIPTS} ${PREFIX}/bin
+.endif
+ @${MKDIR} ${DATADIR}/materials
+ cd ${WRKSRC}/materials && ${INSTALL_DATA} * ${DATADIR}/materials
+
+ cd ${WRKSRC}/doc && ${INSTALL_MAN} ${MANL} ${MANLPREFIX}/man/manl
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}/html
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} R3D_manual.pdf ${DOCSDIR}
+ cd ${WRKSRC}/html && ${INSTALL_DATA} * ${DOCSDIR}/html
+
+ @${MKDIR} ${EXAMPLESDIR}/msms
+ cd ${WRKSRC}/examples && ${INSTALL_DATA} *.* ${EXAMPLESDIR}
+ cd ${WRKSRC}/examples/msms && ${INSTALL_DATA} * ${EXAMPLESDIR}/msms
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/raster3d/distinfo b/graphics/raster3d/distinfo
new file mode 100644
index 000000000000..7f261902451c
--- /dev/null
+++ b/graphics/raster3d/distinfo
@@ -0,0 +1,3 @@
+MD5 (Raster3D_2.7d.tar.gz) = 755445130a4292abf047cd6740b919b2
+SHA256 (Raster3D_2.7d.tar.gz) = 80c2442e38291473b6d66475b7a6511f34868ecfbec7e553b444a0820db50e91
+SIZE (Raster3D_2.7d.tar.gz) = 1724348
diff --git a/graphics/raster3d/files/extrapatch-avs2ps.c b/graphics/raster3d/files/extrapatch-avs2ps.c
new file mode 100644
index 000000000000..d610a5d85d41
--- /dev/null
+++ b/graphics/raster3d/files/extrapatch-avs2ps.c
@@ -0,0 +1,11 @@
+--- avs2ps.c.orig Fri Apr 28 15:34:10 2006
++++ avs2ps.c Fri Apr 28 15:35:09 2006
+@@ -10,7 +10,7 @@
+ #include <math.h>
+ #include <string.h>
+ #include <stdlib.h>
+-#include <netinet/in.h>
++#include "in.h"
+
+ #ifdef WIN32
+ #define random rand
diff --git a/graphics/raster3d/files/extrapatch-in.h b/graphics/raster3d/files/extrapatch-in.h
new file mode 100644
index 000000000000..e97a127f34c7
--- /dev/null
+++ b/graphics/raster3d/files/extrapatch-in.h
@@ -0,0 +1,521 @@
+--- in.h.orig Fri Apr 28 15:38:06 2006
++++ in.h Fri Apr 28 15:38:06 2006
+@@ -0,0 +1,518 @@
++/*
++ * Copyright (c) 1982, 1986, 1990, 1993
++ * The Regents of the University of California. All rights reserved.
++ *
++ * Redistribution and use in source and binary forms, with or without
++ * modification, are permitted provided that the following conditions
++ * are met:
++ * 1. Redistributions of source code must retain the above copyright
++ * notice, this list of conditions and the following disclaimer.
++ * 2. Redistributions in binary form must reproduce the above copyright
++ * notice, this list of conditions and the following disclaimer in the
++ * documentation and/or other materials provided with the distribution.
++ * 3. All advertising materials mentioning features or use of this software
++ * must display the following acknowledgement:
++ * This product includes software developed by the University of
++ * California, Berkeley and its contributors.
++ * 4. Neither the name of the University nor the names of its contributors
++ * may be used to endorse or promote products derived from this software
++ * without specific prior written permission.
++ *
++ * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
++ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
++ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
++ * ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
++ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
++ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
++ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
++ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
++ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
++ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
++ * SUCH DAMAGE.
++ *
++ * @(#)in.h 8.3 (Berkeley) 1/3/94
++ * $FreeBSD: /tmp/pcvs/ports/graphics/raster3d/files/Attic/extrapatch-in.h,v 1.1 2006-04-28 14:20:45 ehaupt Exp $
++ */
++
++#ifndef _NETINET_IN_H_
++#define _NETINET_IN_H_
++
++#include <sys/types.h>
++
++/*
++ * Constants and structures defined by the internet system,
++ * Per RFC 790, September 1981, and numerous additions.
++ */
++
++/*
++ * Protocols (RFC 1700)
++ */
++#define IPPROTO_IP 0 /* dummy for IP */
++#define IPPROTO_HOPOPTS 0 /* IP6 hop-by-hop options */
++#define IPPROTO_ICMP 1 /* control message protocol */
++#define IPPROTO_IGMP 2 /* group mgmt protocol */
++#define IPPROTO_GGP 3 /* gateway^2 (deprecated) */
++#define IPPROTO_IPV4 4 /* IPv4 encapsulation */
++#define IPPROTO_IPIP IPPROTO_IPV4 /* for compatibility */
++#define IPPROTO_TCP 6 /* tcp */
++#define IPPROTO_ST 7 /* Stream protocol II */
++#define IPPROTO_EGP 8 /* exterior gateway protocol */
++#define IPPROTO_PIGP 9 /* private interior gateway */
++#define IPPROTO_RCCMON 10 /* BBN RCC Monitoring */
++#define IPPROTO_NVPII 11 /* network voice protocol*/
++#define IPPROTO_PUP 12 /* pup */
++#define IPPROTO_ARGUS 13 /* Argus */
++#define IPPROTO_EMCON 14 /* EMCON */
++#define IPPROTO_XNET 15 /* Cross Net Debugger */
++#define IPPROTO_CHAOS 16 /* Chaos*/
++#define IPPROTO_UDP 17 /* user datagram protocol */
++#define IPPROTO_MUX 18 /* Multiplexing */
++#define IPPROTO_MEAS 19 /* DCN Measurement Subsystems */
++#define IPPROTO_HMP 20 /* Host Monitoring */
++#define IPPROTO_PRM 21 /* Packet Radio Measurement */
++#define IPPROTO_IDP 22 /* xns idp */
++#define IPPROTO_TRUNK1 23 /* Trunk-1 */
++#define IPPROTO_TRUNK2 24 /* Trunk-2 */
++#define IPPROTO_LEAF1 25 /* Leaf-1 */
++#define IPPROTO_LEAF2 26 /* Leaf-2 */
++#define IPPROTO_RDP 27 /* Reliable Data */
++#define IPPROTO_IRTP 28 /* Reliable Transaction */
++#define IPPROTO_TP 29 /* tp-4 w/ class negotiation */
++#define IPPROTO_BLT 30 /* Bulk Data Transfer */
++#define IPPROTO_NSP 31 /* Network Services */
++#define IPPROTO_INP 32 /* Merit Internodal */
++#define IPPROTO_SEP 33 /* Sequential Exchange */
++#define IPPROTO_3PC 34 /* Third Party Connect */
++#define IPPROTO_IDPR 35 /* InterDomain Policy Routing */
++#define IPPROTO_XTP 36 /* XTP */
++#define IPPROTO_DDP 37 /* Datagram Delivery */
++#define IPPROTO_CMTP 38 /* Control Message Transport */
++#define IPPROTO_TPXX 39 /* TP++ Transport */
++#define IPPROTO_IL 40 /* IL transport protocol */
++#define IPPROTO_IPV6 41 /* IP6 header */
++#define IPPROTO_SDRP 42 /* Source Demand Routing */
++#define IPPROTO_ROUTING 43 /* IP6 routing header */
++#define IPPROTO_FRAGMENT 44 /* IP6 fragmentation header */
++#define IPPROTO_IDRP 45 /* InterDomain Routing*/
++#define IPPROTO_RSVP 46 /* resource reservation */
++#define IPPROTO_GRE 47 /* General Routing Encap. */
++#define IPPROTO_MHRP 48 /* Mobile Host Routing */
++#define IPPROTO_BHA 49 /* BHA */
++#define IPPROTO_ESP 50 /* IP6 Encap Sec. Payload */
++#define IPPROTO_AH 51 /* IP6 Auth Header */
++#define IPPROTO_INLSP 52 /* Integ. Net Layer Security */
++#define IPPROTO_SWIPE 53 /* IP with encryption */
++#define IPPROTO_NHRP 54 /* Next Hop Resolution */
++#define IPPROTO_MOBILE 55 /* IP Mobility */
++#define IPPROTO_TLSP 56 /* Transport Layer Security */
++#define IPPROTO_SKIP 57 /* SKIP */
++#define IPPROTO_ICMPV6 58 /* ICMP6 */
++#define IPPROTO_NONE 59 /* IP6 no next header */
++#define IPPROTO_DSTOPTS 60 /* IP6 destination option */
++#define IPPROTO_AHIP 61 /* any host internal protocol */
++#define IPPROTO_CFTP 62 /* CFTP */
++#define IPPROTO_HELLO 63 /* "hello" routing protocol */
++#define IPPROTO_SATEXPAK 64 /* SATNET/Backroom EXPAK */
++#define IPPROTO_KRYPTOLAN 65 /* Kryptolan */
++#define IPPROTO_RVD 66 /* Remote Virtual Disk */
++#define IPPROTO_IPPC 67 /* Pluribus Packet Core */
++#define IPPROTO_ADFS 68 /* Any distributed FS */
++#define IPPROTO_SATMON 69 /* Satnet Monitoring */
++#define IPPROTO_VISA 70 /* VISA Protocol */
++#define IPPROTO_IPCV 71 /* Packet Core Utility */
++#define IPPROTO_CPNX 72 /* Comp. Prot. Net. Executive */
++#define IPPROTO_CPHB 73 /* Comp. Prot. HeartBeat */
++#define IPPROTO_WSN 74 /* Wang Span Network */
++#define IPPROTO_PVP 75 /* Packet Video Protocol */
++#define IPPROTO_BRSATMON 76 /* BackRoom SATNET Monitoring */
++#define IPPROTO_ND 77 /* Sun net disk proto (temp.) */
++#define IPPROTO_WBMON 78 /* WIDEBAND Monitoring */
++#define IPPROTO_WBEXPAK 79 /* WIDEBAND EXPAK */
++#define IPPROTO_EON 80 /* ISO cnlp */
++#define IPPROTO_VMTP 81 /* VMTP */
++#define IPPROTO_SVMTP 82 /* Secure VMTP */
++#define IPPROTO_VINES 83 /* Banyon VINES */
++#define IPPROTO_TTP 84 /* TTP */
++#define IPPROTO_IGP 85 /* NSFNET-IGP */
++#define IPPROTO_DGP 86 /* dissimilar gateway prot. */
++#define IPPROTO_TCF 87 /* TCF */
++#define IPPROTO_IGRP 88 /* Cisco/GXS IGRP */
++#define IPPROTO_OSPFIGP 89 /* OSPFIGP */
++#define IPPROTO_SRPC 90 /* Strite RPC protocol */
++#define IPPROTO_LARP 91 /* Locus Address Resoloution */
++#define IPPROTO_MTP 92 /* Multicast Transport */
++#define IPPROTO_AX25 93 /* AX.25 Frames */
++#define IPPROTO_IPEIP 94 /* IP encapsulated in IP */
++#define IPPROTO_MICP 95 /* Mobile Int.ing control */
++#define IPPROTO_SCCSP 96 /* Semaphore Comm. security */
++#define IPPROTO_ETHERIP 97 /* Ethernet IP encapsulation */
++#define IPPROTO_ENCAP 98 /* encapsulation header */
++#define IPPROTO_APES 99 /* any private encr. scheme */
++#define IPPROTO_GMTP 100 /* GMTP*/
++#define IPPROTO_IPCOMP 108 /* payload compression (IPComp) */
++/* 101-254: Partly Unassigned */
++#define IPPROTO_PIM 103 /* Protocol Independent Mcast */
++#define IPPROTO_PGM 113 /* PGM */
++/* 255: Reserved */
++/* BSD Private, local use, namespace incursion */
++#define IPPROTO_DIVERT 254 /* divert pseudo-protocol */
++#define IPPROTO_RAW 255 /* raw IP packet */
++#define IPPROTO_MAX 256
++
++/* last return value of *_input(), meaning "all job for this pkt is done". */
++#define IPPROTO_DONE 257
++
++/*
++ * Local port number conventions:
++ *
++ * When a user does a bind(2) or connect(2) with a port number of zero,
++ * a non-conflicting local port address is chosen.
++ * The default range is IPPORT_RESERVED through
++ * IPPORT_USERRESERVED, although that is settable by sysctl.
++ *
++ * A user may set the IPPROTO_IP option IP_PORTRANGE to change this
++ * default assignment range.
++ *
++ * The value IP_PORTRANGE_DEFAULT causes the default behavior.
++ *
++ * The value IP_PORTRANGE_HIGH changes the range of candidate port numbers
++ * into the "high" range. These are reserved for client outbound connections
++ * which do not want to be filtered by any firewalls.
++ *
++ * The value IP_PORTRANGE_LOW changes the range to the "low" are
++ * that is (by convention) restricted to privileged processes. This
++ * convention is based on "vouchsafe" principles only. It is only secure
++ * if you trust the remote host to restrict these ports.
++ *
++ * The default range of ports and the high range can be changed by
++ * sysctl(3). (net.inet.ip.port{hi,low}{first,last}_auto)
++ *
++ * Changing those values has bad security implications if you are
++ * using a a stateless firewall that is allowing packets outside of that
++ * range in order to allow transparent outgoing connections.
++ *
++ * Such a firewall configuration will generally depend on the use of these
++ * default values. If you change them, you may find your Security
++ * Administrator looking for you with a heavy object.
++ *
++ * For a slightly more orthodox text view on this:
++ *
++ * ftp://ftp.isi.edu/in-notes/iana/assignments/port-numbers
++ *
++ * port numbers are divided into three ranges:
++ *
++ * 0 - 1023 Well Known Ports
++ * 1024 - 49151 Registered Ports
++ * 49152 - 65535 Dynamic and/or Private Ports
++ *
++ */
++
++/*
++ * Ports < IPPORT_RESERVED are reserved for
++ * privileged processes (e.g. root). (IP_PORTRANGE_LOW)
++ * Ports > IPPORT_USERRESERVED are reserved
++ * for servers, not necessarily privileged. (IP_PORTRANGE_DEFAULT)
++ */
++#define IPPORT_RESERVED 1024
++#define IPPORT_USERRESERVED 5000
++
++/*
++ * Default local port range to use by setting IP_PORTRANGE_HIGH
++ */
++#define IPPORT_HIFIRSTAUTO 49152
++#define IPPORT_HILASTAUTO 65535
++
++/*
++ * Scanning for a free reserved port return a value below IPPORT_RESERVED,
++ * but higher than IPPORT_RESERVEDSTART. Traditionally the start value was
++ * 512, but that conflicts with some well-known-services that firewalls may
++ * have a fit if we use.
++ */
++#define IPPORT_RESERVEDSTART 600
++
++/*
++ * Internet address (a structure for historical reasons)
++ */
++struct in_addr {
++ in_addr_t s_addr;
++};
++
++/*
++ * Definitions of bits in internet address integers.
++ * On subnets, the decomposition of addresses to host and net parts
++ * is done according to subnet mask, not the masks here.
++ */
++#define IN_CLASSA(i) (((u_int32_t)(i) & 0x80000000) == 0)
++#define IN_CLASSA_NET 0xff000000
++#define IN_CLASSA_NSHIFT 24
++#define IN_CLASSA_HOST 0x00ffffff
++#define IN_CLASSA_MAX 128
++
++#define IN_CLASSB(i) (((u_int32_t)(i) & 0xc0000000) == 0x80000000)
++#define IN_CLASSB_NET 0xffff0000
++#define IN_CLASSB_NSHIFT 16
++#define IN_CLASSB_HOST 0x0000ffff
++#define IN_CLASSB_MAX 65536
++
++#define IN_CLASSC(i) (((u_int32_t)(i) & 0xe0000000) == 0xc0000000)
++#define IN_CLASSC_NET 0xffffff00
++#define IN_CLASSC_NSHIFT 8
++#define IN_CLASSC_HOST 0x000000ff
++
++#define IN_CLASSD(i) (((u_int32_t)(i) & 0xf0000000) == 0xe0000000)
++#define IN_CLASSD_NET 0xf0000000 /* These ones aren't really */
++#define IN_CLASSD_NSHIFT 28 /* net and host fields, but */
++#define IN_CLASSD_HOST 0x0fffffff /* routing needn't know. */
++#define IN_MULTICAST(i) IN_CLASSD(i)
++
++#define IN_EXPERIMENTAL(i) (((u_int32_t)(i) & 0xf0000000) == 0xf0000000)
++#define IN_BADCLASS(i) (((u_int32_t)(i) & 0xf0000000) == 0xf0000000)
++
++#define INADDR_ANY (u_int32_t)0x00000000
++#define INADDR_LOOPBACK (u_int32_t)0x7f000001
++#define INADDR_BROADCAST (u_int32_t)0xffffffff /* must be masked */
++#ifndef _KERNEL
++#define INADDR_NONE 0xffffffff /* -1 return */
++#endif
++
++#define INADDR_UNSPEC_GROUP (u_int32_t)0xe0000000 /* 224.0.0.0 */
++#define INADDR_ALLHOSTS_GROUP (u_int32_t)0xe0000001 /* 224.0.0.1 */
++#define INADDR_ALLRTRS_GROUP (u_int32_t)0xe0000002 /* 224.0.0.2 */
++#define INADDR_MAX_LOCAL_GROUP (u_int32_t)0xe00000ff /* 224.0.0.255 */
++
++#define IN_LOOPBACKNET 127 /* official! */
++
++/*
++ * Socket address, internet style.
++ */
++struct sockaddr_in {
++ u_char sin_len;
++ u_char sin_family;
++ u_short sin_port;
++ struct in_addr sin_addr;
++ char sin_zero[8];
++};
++
++#define INET_ADDRSTRLEN 16
++
++/*
++ * Options for use with [gs]etsockopt at the IP level.
++ * First word of comment is data type; bool is stored in int.
++ */
++#define IP_OPTIONS 1 /* buf/ip_opts; set/get IP options */
++#define IP_HDRINCL 2 /* int; header is included with data */
++#define IP_TOS 3 /* int; IP type of service and preced. */
++#define IP_TTL 4 /* int; IP time to live */
++#define IP_RECVOPTS 5 /* bool; receive all IP opts w/dgram */
++#define IP_RECVRETOPTS 6 /* bool; receive IP opts for response */
++#define IP_RECVDSTADDR 7 /* bool; receive IP dst addr w/dgram */
++#define IP_RETOPTS 8 /* ip_opts; set/get IP options */
++#define IP_MULTICAST_IF 9 /* u_char; set/get IP multicast i/f */
++#define IP_MULTICAST_TTL 10 /* u_char; set/get IP multicast ttl */
++#define IP_MULTICAST_LOOP 11 /* u_char; set/get IP multicast loopback */
++#define IP_ADD_MEMBERSHIP 12 /* ip_mreq; add an IP group membership */
++#define IP_DROP_MEMBERSHIP 13 /* ip_mreq; drop an IP group membership */
++#define IP_MULTICAST_VIF 14 /* set/get IP mcast virt. iface */
++#define IP_RSVP_ON 15 /* enable RSVP in kernel */
++#define IP_RSVP_OFF 16 /* disable RSVP in kernel */
++#define IP_RSVP_VIF_ON 17 /* set RSVP per-vif socket */
++#define IP_RSVP_VIF_OFF 18 /* unset RSVP per-vif socket */
++#define IP_PORTRANGE 19 /* int; range to choose for unspec port */
++#define IP_RECVIF 20 /* bool; receive reception if w/dgram */
++/* for IPSEC */
++#define IP_IPSEC_POLICY 21 /* int; set/get security policy */
++#define IP_FAITH 22 /* bool; accept FAITH'ed connections */
++
++#define IP_ONESBCAST 23 /* bool: send all-ones broadcast */
++
++#define IP_FW_TABLE_ADD 40 /* add entry */
++#define IP_FW_TABLE_DEL 41 /* delete entry */
++#define IP_FW_TABLE_FLUSH 42 /* flush table */
++#define IP_FW_TABLE_GETSIZE 43 /* get table size */
++#define IP_FW_TABLE_LIST 44 /* list table contents */
++
++#define IP_FW_ADD 50 /* add a firewall rule to chain */
++#define IP_FW_DEL 51 /* delete a firewall rule from chain */
++#define IP_FW_FLUSH 52 /* flush firewall rule chain */
++#define IP_FW_ZERO 53 /* clear single/all firewall counter(s) */
++#define IP_FW_GET 54 /* get entire firewall rule chain */
++#define IP_FW_RESETLOG 55 /* reset logging counters */
++
++#define IP_DUMMYNET_CONFIGURE 60 /* add/configure a dummynet pipe */
++#define IP_DUMMYNET_DEL 61 /* delete a dummynet pipe from chain */
++#define IP_DUMMYNET_FLUSH 62 /* flush dummynet */
++#define IP_DUMMYNET_GET 64 /* get entire dummynet pipes */
++
++/*
++ * Defaults and limits for options
++ */
++#define IP_DEFAULT_MULTICAST_TTL 1 /* normally limit m'casts to 1 hop */
++#define IP_DEFAULT_MULTICAST_LOOP 1 /* normally hear sends if a member */
++#define IP_MAX_MEMBERSHIPS 20 /* per socket */
++
++/*
++ * Argument structure for IP_ADD_MEMBERSHIP and IP_DROP_MEMBERSHIP.
++ */
++struct ip_mreq {
++ struct in_addr imr_multiaddr; /* IP multicast address of group */
++ struct in_addr imr_interface; /* local IP address of interface */
++};
++
++/*
++ * Argument for IP_PORTRANGE:
++ * - which range to search when port is unspecified at bind() or connect()
++ */
++#define IP_PORTRANGE_DEFAULT 0 /* default range */
++#define IP_PORTRANGE_HIGH 1 /* "high" - request firewall bypass */
++#define IP_PORTRANGE_LOW 2 /* "low" - vouchsafe security */
++
++/*
++ * Definitions for inet sysctl operations.
++ *
++ * Third level is protocol number.
++ * Fourth level is desired variable within that protocol.
++ */
++#define IPPROTO_MAXID (IPPROTO_AH + 1) /* don't list to IPPROTO_MAX */
++
++#define CTL_IPPROTO_NAMES { \
++ { "ip", CTLTYPE_NODE }, \
++ { "icmp", CTLTYPE_NODE }, \
++ { "igmp", CTLTYPE_NODE }, \
++ { "ggp", CTLTYPE_NODE }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { "tcp", CTLTYPE_NODE }, \
++ { 0, 0 }, \
++ { "egp", CTLTYPE_NODE }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { "pup", CTLTYPE_NODE }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { "udp", CTLTYPE_NODE }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { "idp", CTLTYPE_NODE }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { "ipsec", CTLTYPE_NODE }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, \
++ { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, \
++ { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, \
++ { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, \
++ { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, \
++ { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, \
++ { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, \
++ { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, \
++ { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { 0, 0 }, \
++ { "pim", CTLTYPE_NODE }, \
++}
++
++/*
++ * Names for IP sysctl objects
++ */
++#define IPCTL_FORWARDING 1 /* act as router */
++#define IPCTL_SENDREDIRECTS 2 /* may send redirects when forwarding */
++#define IPCTL_DEFTTL 3 /* default TTL */
++#ifdef notyet
++#define IPCTL_DEFMTU 4 /* default MTU */
++#endif
++#define IPCTL_RTEXPIRE 5 /* cloned route expiration time */
++#define IPCTL_RTMINEXPIRE 6 /* min value for expiration time */
++#define IPCTL_RTMAXCACHE 7 /* trigger level for dynamic expire */
++#define IPCTL_SOURCEROUTE 8 /* may perform source routes */
++#define IPCTL_DIRECTEDBROADCAST 9 /* may re-broadcast received packets */
++#define IPCTL_INTRQMAXLEN 10 /* max length of netisr queue */
++#define IPCTL_INTRQDROPS 11 /* number of netisr q drops */
++#define IPCTL_STATS 12 /* ipstat structure */
++#define IPCTL_ACCEPTSOURCEROUTE 13 /* may accept source routed packets */
++#define IPCTL_FASTFORWARDING 14 /* use fast IP forwarding code */
++#define IPCTL_KEEPFAITH 15 /* FAITH IPv4->IPv6 translater ctl */
++#define IPCTL_GIF_TTL 16 /* default TTL for gif encap packet */
++#define IPCTL_MAXID 17
++
++#define IPCTL_NAMES { \
++ { 0, 0 }, \
++ { "forwarding", CTLTYPE_INT }, \
++ { "redirect", CTLTYPE_INT }, \
++ { "ttl", CTLTYPE_INT }, \
++ { "mtu", CTLTYPE_INT }, \
++ { "rtexpire", CTLTYPE_INT }, \
++ { "rtminexpire", CTLTYPE_INT }, \
++ { "rtmaxcache", CTLTYPE_INT }, \
++ { "sourceroute", CTLTYPE_INT }, \
++ { "directed-broadcast", CTLTYPE_INT }, \
++ { "intr-queue-maxlen", CTLTYPE_INT }, \
++ { "intr-queue-drops", CTLTYPE_INT }, \
++ { "stats", CTLTYPE_STRUCT }, \
++ { "accept_sourceroute", CTLTYPE_INT }, \
++ { "fastforwarding", CTLTYPE_INT }, \
++}
++
++#ifdef _KERNEL
++struct ifnet; struct mbuf; /* forward declarations for Standard C */
++#endif
++
++/* INET6 stuff */
++#define __KAME_NETINET_IN_H_INCLUDED_
++#include <netinet6/in6.h>
++#undef __KAME_NETINET_IN_H_INCLUDED_
++
++#ifdef _KERNEL
++
++int in_broadcast __P((struct in_addr, struct ifnet *));
++int in_canforward __P((struct in_addr));
++int in_cksum __P((struct mbuf *, int));
++int in_localaddr __P((struct in_addr));
++char *inet_ntoa __P((struct in_addr)); /* in libkern */
++
++int prison_ip __P((struct proc *p, int flag, u_int32_t *ip));
++void prison_remote_ip __P((struct proc *p, int flag, u_int32_t *ip));
++
++#define in_hosteq(s, t) ((s).s_addr == (t).s_addr)
++#define in_nullhost(x) ((x).s_addr == INADDR_ANY)
++
++#define satosin(sa) ((struct sockaddr_in *)(sa))
++#define sintosa(sin) ((struct sockaddr *)(sin))
++#define ifatoia(ifa) ((struct in_ifaddr *)(ifa))
++
++#endif
++
++#endif
diff --git a/graphics/raster3d/files/patch-Makefile b/graphics/raster3d/files/patch-Makefile
new file mode 100644
index 000000000000..74b2e617fcc7
--- /dev/null
+++ b/graphics/raster3d/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile.orig Wed Apr 12 19:46:10 2006
++++ Makefile Fri Apr 28 02:48:06 2006
+@@ -156,6 +156,16 @@
+ @echo FFLAGS = \${CFLAGS} >> Makefile.incl
+ @echo RM = /bin/rm -f >> Makefile.incl
+
++freebsd: strip-for-g77
++ @cp Makefile.template Makefile.incl
++ @echo OS = freebsd >> Makefile.incl
++ @echo CC = ${CC} >> Makefile.incl
++ @echo CFLAGS = ${CFLAGS} >> Makefile.incl
++ @echo FC = f77 >> Makefile.incl
++ @echo FFLAGS = ${FFLAGS} >> Makefile.incl
++ @echo RM = /bin/rm -f >> Makefile.incl
++ @echo OSDEFS = -DLINUX -DNETWORKBYTEORDER >> Makefile.incl
++ @echo include Makefile.package >> Makefile.incl
+
+ strip-for-g77: render.f.bak normal3d.f.bak rastep.f.bak
+ render.f.bak:
diff --git a/graphics/raster3d/pkg-descr b/graphics/raster3d/pkg-descr
new file mode 100644
index 000000000000..d3b23e9438aa
--- /dev/null
+++ b/graphics/raster3d/pkg-descr
@@ -0,0 +1,17 @@
+Raster3D is a set of tools for generating high quality raster images of
+proteins or other molecules.
+
+The core program renders spheres, triangles, cylinders, and quadric
+surfaces with specular highlighting, Phong shading, and shadowing. It
+uses an efficient software Z-buffer algorithm which is independent of
+any graphics hardware.
+
+Ancillary programs process atomic coordinates from PDB files into
+rendering descriptions for pictures composed of ribbons, space-filling
+atoms, bonds, ball+stick, etc.
+
+Raster3D can also be used to render pictures composed in other programs
+such as Molscript in glorious 3D with highlights, shadowing, etc. Output
+is to pixel image files with 24 bits of color information per pixel.
+
+WWW: http://skuld.bmsc.washington.edu/raster3d/
diff --git a/graphics/raster3d/pkg-plist b/graphics/raster3d/pkg-plist
new file mode 100644
index 000000000000..b082e38aaf59
--- /dev/null
+++ b/graphics/raster3d/pkg-plist
@@ -0,0 +1,157 @@
+bin/avs2ps
+bin/balls
+bin/rastep
+bin/render
+bin/ribbon
+bin/rings3d
+bin/rods
+bin/normal3d
+%%IMAGEMAGICK%%bin/label3d
+%%IMAGEMAGICK%%bin/stereo3d
+%%PORTDOCS%%%%DOCSDIR%%/html/README
+%%PORTDOCS%%%%DOCSDIR%%/html/avs2ps.html
+%%PORTDOCS%%%%DOCSDIR%%/html/balls.html
+%%PORTDOCS%%%%DOCSDIR%%/html/index_button.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/label3d.html
+%%PORTDOCS%%%%DOCSDIR%%/html/normal3d.html
+%%PORTDOCS%%%%DOCSDIR%%/html/pdb_anisou.html
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_animation.html
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_colorpicker.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_colorpicker.html
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_colors.html
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_docbkg.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_docstyle.css
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_example1.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_example2.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_example5.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_example6.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_example6.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_example7.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_example8.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_example9.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_examples.html
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_filters.html
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_hints.html
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_icon.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_labels.html
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_msms.png
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_obj15.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_obj19.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_stereo7.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/r3d_transparent.html
+%%PORTDOCS%%%%DOCSDIR%%/html/r3dtops.html
+%%PORTDOCS%%%%DOCSDIR%%/html/r3dtops_tex1.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/r3dtops_tex2.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/r3dtops_tex3.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/rastep.html
+%%PORTDOCS%%%%DOCSDIR%%/html/rastep_options.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/raster3d.html
+%%PORTDOCS%%%%DOCSDIR%%/html/render.html
+%%PORTDOCS%%%%DOCSDIR%%/html/rgb_black.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/rgb_white.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/rgbmap_black.html
+%%PORTDOCS%%%%DOCSDIR%%/html/rgbmap_white.html
+%%PORTDOCS%%%%DOCSDIR%%/html/rgbtext.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ribbon.html
+%%PORTDOCS%%%%DOCSDIR%%/html/rings3d.html
+%%PORTDOCS%%%%DOCSDIR%%/html/rods.html
+%%PORTDOCS%%%%DOCSDIR%%/html/stereo3d.html
+%%PORTDOCS%%%%DOCSDIR%%/R3D_manual.pdf
+%%PORTDOCS%%%%EXAMPLESDIR%%/msms/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/msms/msms2r3d.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/msms/msms_example.script
+%%PORTDOCS%%%%EXAMPLESDIR%%/LT.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/README.examples
+%%PORTDOCS%%%%EXAMPLESDIR%%/chaincolours.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/clip.r3d
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex5.jpeg
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex5_matrix.r3d
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex7_header.r3d
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex7_helix.r3d
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex7_labels.r3d
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex7_tex.r3d
+%%PORTDOCS%%%%EXAMPLESDIR%%/ex7_titles.r3d
+%%PORTDOCS%%%%EXAMPLESDIR%%/example1.r3d
+%%PORTDOCS%%%%EXAMPLESDIR%%/example1.script
+%%PORTDOCS%%%%EXAMPLESDIR%%/example2.script
+%%PORTDOCS%%%%EXAMPLESDIR%%/example2.sgi
+%%PORTDOCS%%%%EXAMPLESDIR%%/example3.mol
+%%PORTDOCS%%%%EXAMPLESDIR%%/example3.r3d
+%%PORTDOCS%%%%EXAMPLESDIR%%/example3.script
+%%PORTDOCS%%%%EXAMPLESDIR%%/example4.script
+%%PORTDOCS%%%%EXAMPLESDIR%%/example5.r3d
+%%PORTDOCS%%%%EXAMPLESDIR%%/example5.script
+%%PORTDOCS%%%%EXAMPLESDIR%%/example6.r3d
+%%PORTDOCS%%%%EXAMPLESDIR%%/example6.script
+%%PORTDOCS%%%%EXAMPLESDIR%%/example7.jpeg
+%%PORTDOCS%%%%EXAMPLESDIR%%/example7.r3d
+%%PORTDOCS%%%%EXAMPLESDIR%%/example7.script
+%%PORTDOCS%%%%EXAMPLESDIR%%/example8.script
+%%PORTDOCS%%%%EXAMPLESDIR%%/example9.script
+%%PORTDOCS%%%%EXAMPLESDIR%%/gal_srf.r3d.gz
+%%PORTDOCS%%%%EXAMPLESDIR%%/header1.r3d
+%%PORTDOCS%%%%EXAMPLESDIR%%/header2.r3d
+%%PORTDOCS%%%%EXAMPLESDIR%%/header4.r3d
+%%PORTDOCS%%%%EXAMPLESDIR%%/header8.r3d
+%%PORTDOCS%%%%EXAMPLESDIR%%/plane.r3d
+%%PORTDOCS%%%%EXAMPLESDIR%%/sugarG.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/sugarcolours.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/sugars.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/transparent.r3d
+%%DATADIR%%/materials/2-sided.r3d
+%%DATADIR%%/materials/backdrop_1.r3d
+%%DATADIR%%/materials/backdrop_2.r3d
+%%DATADIR%%/materials/backdrop_3.r3d
+%%DATADIR%%/materials/backface.r3d
+%%DATADIR%%/materials/basement.r3d
+%%DATADIR%%/materials/black.r3d
+%%DATADIR%%/materials/blue.r3d
+%%DATADIR%%/materials/bronze.r3d
+%%DATADIR%%/materials/brown.r3d
+%%DATADIR%%/materials/cpk.colours
+%%DATADIR%%/materials/cyan.r3d
+%%DATADIR%%/materials/darkblue.r3d
+%%DATADIR%%/materials/darkgreen.r3d
+%%DATADIR%%/materials/darkgrey.r3d
+%%DATADIR%%/materials/darkred.r3d
+%%DATADIR%%/materials/dna.colours
+%%DATADIR%%/materials/end_material.r3d
+%%DATADIR%%/materials/floor.r3d
+%%DATADIR%%/materials/fog.r3d
+%%DATADIR%%/materials/forestgreen.r3d
+%%DATADIR%%/materials/gold.r3d
+%%DATADIR%%/materials/green.r3d
+%%DATADIR%%/materials/grey.r3d
+%%DATADIR%%/materials/lightblue.r3d
+%%DATADIR%%/materials/lightgreen.r3d
+%%DATADIR%%/materials/lightgrey.r3d
+%%DATADIR%%/materials/lightorange.r3d
+%%DATADIR%%/materials/lightyellow.r3d
+%%DATADIR%%/materials/lilac.r3d
+%%DATADIR%%/materials/matte.r3d
+%%DATADIR%%/materials/moccasin.r3d
+%%DATADIR%%/materials/mycolors.pdb
+%%DATADIR%%/materials/orange.r3d
+%%DATADIR%%/materials/orchid.r3d
+%%DATADIR%%/materials/pearl.r3d
+%%DATADIR%%/materials/pink.r3d
+%%DATADIR%%/materials/purple.r3d
+%%DATADIR%%/materials/red.r3d
+%%DATADIR%%/materials/residue.colours
+%%DATADIR%%/materials/shapely.colours
+%%DATADIR%%/materials/silver.r3d
+%%DATADIR%%/materials/translucent.r3d
+%%DATADIR%%/materials/translucent_30.r3d
+%%DATADIR%%/materials/translucent_60.r3d
+%%DATADIR%%/materials/translucent_90.r3d
+%%DATADIR%%/materials/transparent.r3d
+%%DATADIR%%/materials/transparent0.r3d
+%%DATADIR%%/materials/transparent1.r3d
+%%DATADIR%%/materials/white.r3d
+%%DATADIR%%/materials/yellow.r3d
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/msms
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/materials
+@dirrm %%DATADIR%%