aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/rawtherapee/Makefile
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2010-01-11 13:04:14 +0800
committerstas <stas@FreeBSD.org>2010-01-11 13:04:14 +0800
commit025bf95661deab551b7560db0cf38506b7af5048 (patch)
treec7aca12d7ffc87a2ca0f0eb56c2dd471e48af34b /graphics/rawtherapee/Makefile
parent681cce60e57aa2b108f543db8d52141c90e6eeb6 (diff)
downloadfreebsd-ports-gnome-025bf95661deab551b7560db0cf38506b7af5048.tar.gz
freebsd-ports-gnome-025bf95661deab551b7560db0cf38506b7af5048.tar.zst
freebsd-ports-gnome-025bf95661deab551b7560db0cf38506b7af5048.zip
- Add graphics/rawtherapee, a powerful RAW image processing appliction.
WWW: http://www.rawtherapee.com
Diffstat (limited to 'graphics/rawtherapee/Makefile')
-rw-r--r--graphics/rawtherapee/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
new file mode 100644
index 000000000000..cf635024220d
--- /dev/null
+++ b/graphics/rawtherapee/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: rawtherapee
+# Date created: 01/10/2010
+# Whom: stas
+#
+# $FreeBSD$
+#
+
+PORTNAME= rawtherapee
+PORTVERSION= 3.0
+CATEGORIES= graphics
+MASTER_SITES= http://www.rawtherapee.com/
+DISTNAME= ${PORTNAME}${PORTVERSION:S,.,,g}src
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= A powerful RAW image processing application
+
+LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ iptcdata.3:${PORTSDIR}/graphics/libiptcdata \
+ jpeg.10:${PORTSDIR}/graphics/jpeg \
+ lcms.1:${PORTSDIR}/graphics/lcms \
+ png:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
+USE_CMAKE= yes
+USE_GNOME= gtk20 glib20
+USE_LDCONFIG= yes
+CFLAGS+= -I${LOCALBASE}/include -fPIC
+LDFLAGS+= -L${LOCALBASE}/lib
+CMAKE_ENV= CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+SUB_FILES= rawtherapee
+SUB_LIST= RTDIR="${RTDIR}"
+
+WRKSRC= ${WRKDIR}/RawTherapee${PORTVERSION:S,.,,g}
+RTDIR= ${PREFIX}/libdata/${PORTNAME}
+
+OPTIONS= OPTIMIZED_CFLAGS "Use optimized CFLAGS" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
+CFLAGS+= -O3 -ffast-math -fexpensive-optimizations \
+ -funroll-loops -msse
+.endif
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/rtengine/librtengine.so ${PREFIX}/lib
+ ${MKDIR} ${RTDIR}/
+ ${INSTALL_PROGRAM} ${WRKSRC}/rtgui/rth ${RTDIR}/
+ (cd ${WRKSRC}/release && ${COPYTREE_SHARE} \* ${RTDIR}/)
+ ${INSTALL_DATA} ${WRKSRC}/options.lin ${RTDIR}/options
+ ${INSTALL_SCRIPT} ${WRKDIR}/rawtherapee ${PREFIX}/bin/
+
+.include <bsd.port.post.mk>