aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/rawtherapee/Makefile
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2011-09-08 08:07:55 +0800
committerstas <stas@FreeBSD.org>2011-09-08 08:07:55 +0800
commit73c75b09d9493c301f647e23c8891a6adedc4d3b (patch)
treeb1a345a6f6f4b69293cfe39aba3da5835a11838c /graphics/rawtherapee/Makefile
parent8ebad781462d796a0dbba2b3dc4d632b228e852d (diff)
downloadfreebsd-ports-gnome-73c75b09d9493c301f647e23c8891a6adedc4d3b.tar.gz
freebsd-ports-gnome-73c75b09d9493c301f647e23c8891a6adedc4d3b.tar.zst
freebsd-ports-gnome-73c75b09d9493c301f647e23c8891a6adedc4d3b.zip
- Update to 4.0.2.
- Add workaround for Glib's non-UTF8 locale bug.
Diffstat (limited to 'graphics/rawtherapee/Makefile')
-rw-r--r--graphics/rawtherapee/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index b000fd498708..5e3d712accd6 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= rawtherapee
-PORTVERSION= 3.0
-PORTREVISION= 3
+PORTVERSION= 4.0.2
+PORTREVISION= 0
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/
@@ -19,7 +19,7 @@ LICENSE= GPLv3
LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
iptcdata.3:${PORTSDIR}/graphics/libiptcdata \
jpeg.11:${PORTSDIR}/graphics/jpeg \
- lcms.1:${PORTSDIR}/graphics/lcms \
+ lcms2.2:${PORTSDIR}/graphics/lcms2 \
png:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
sigc-2.0:${PORTSDIR}/devel/libsigc++20
@@ -29,6 +29,7 @@ USE_BZIP2= yes
USE_GNOME= gtk20 glib20 pkgconfig
USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include -fPIC ${PTHREAD_CFLAGS}
+CXXFLAGS+= -I${LOCALBASE}/include -fPIC ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CMAKE_ENV= CFLAGS="${CFLAGS}" \
LDFLAGS="${LDFLAGS}"
@@ -36,7 +37,9 @@ CMAKE_ARGS+= -DDOCDIR="${DOCSDIR}" \
-DCREDITSDIR="${DOCSDIR}" \
-DLICENCEDIR="${DOCSDIR}" \
-DDESKTOPDIR="${DESKTOPDIR}" \
- -DDATADIR="${DATADIR}"
+ -DDATADIR="${DATADIR}" \
+ -DCMAKE_C_FLAGS="${CFLAGS}" \
+ -DCMAKE_CXX_FLAGS="${CXXFLAGS}"
SUB_FILES= rawtherapee
SUB_LIST= RTDIR="${RTDIR}"
INSTALLS_ICONS= yes
@@ -52,6 +55,8 @@ OPTIONS= OPTIMIZED_CFLAGS "Use optimized CFLAGS" on \
.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -ffast-math -fexpensive-optimizations \
-funroll-loops -msse
+CXXFLAGS+= -O3 -ffast-math -fexpensive-optimizations \
+ -funroll-loops -msse
.endif
.endif