aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/rawtherapee/Makefile
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-08-08 15:18:24 +0800
committerrm <rm@FreeBSD.org>2012-08-08 15:18:24 +0800
commit898ad6fb496a19d455e8b72a01fa998a5bc5a7c0 (patch)
tree2fd8b34e1a89b57a369a389973739a71e9bb33d3 /graphics/rawtherapee/Makefile
parent4b6af59c36e52ed281655d9c96c257409da49022 (diff)
downloadfreebsd-ports-gnome-898ad6fb496a19d455e8b72a01fa998a5bc5a7c0.tar.gz
freebsd-ports-gnome-898ad6fb496a19d455e8b72a01fa998a5bc5a7c0.tar.zst
freebsd-ports-gnome-898ad6fb496a19d455e8b72a01fa998a5bc5a7c0.zip
- update to 4.0.9
- adjust local patch to new version - pet portlint (drop shlib versions in LIB_DEPENDS) - tab -> space change in pkg-plist:WWW
Diffstat (limited to 'graphics/rawtherapee/Makefile')
-rw-r--r--graphics/rawtherapee/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index f8f79d3b164b..855017e14819 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= rawtherapee
-PORTVERSION= 4.0.8
-PORTREVISION= 1
+PORTVERSION= 4.0.9
CATEGORIES= graphics
MASTER_SITES= GOOGLE_CODE
@@ -16,12 +15,12 @@ COMMENT= A powerful RAW image processing application
LICENSE= GPLv3
-LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
- iptcdata.3:${PORTSDIR}/graphics/libiptcdata \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- lcms2.2:${PORTSDIR}/graphics/lcms2 \
+LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ iptcdata:${PORTSDIR}/graphics/libiptcdata \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ lcms2:${PORTSDIR}/graphics/lcms2 \
png15:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
+ tiff:${PORTSDIR}/graphics/tiff \
sigc-2.0:${PORTSDIR}/devel/libsigc++20
USE_CMAKE= yes
@@ -52,6 +51,11 @@ OPTIONS_DEFINE= OPTIMIZED_CFLAGS OPENMP
OPTIONS_DEFAULT= OPTIMIZED_CFLAGS OPENMP
OPENMP_DESC= Enable multicore processing using OpenMP
+post-patch:
+ @${REINPLACE_CMD} -e 's#<auto_ptr.h>#<memory>#g' \
+ ${WRKSRC}/rtgui/darkframe.h ${WRKSRC}/rtgui/flatfield.h \
+ ${WRKSRC}/rtgui/icmpanel.h
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64" || ${ARCH} == "i386"
@@ -63,10 +67,6 @@ CXXFLAGS+= -O3 -ffast-math -fexpensive-optimizations \
.endif
.endif
-#.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-#BROKEN= Does not compile on ia64, powerpc, or sparc64
-#.endif
-
.if ${PORT_OPTIONS:MOPENMP}
CMAKE_ARGS+= -DOPTION_OMP:BOOL=ON
.else