aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/rayshade
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1999-09-21 15:22:40 +0800
committerasami <asami@FreeBSD.org>1999-09-21 15:22:40 +0800
commita3a19d91beb361f24d0f37201106f0a7fa638c21 (patch)
tree0cf16194b7d6704d07f02ec72d63ff65ac35084f /graphics/rayshade
parent7137ce52f742eb11e58fe41b7d125247ef0d8b8a (diff)
downloadfreebsd-ports-gnome-a3a19d91beb361f24d0f37201106f0a7fa638c21.tar.gz
freebsd-ports-gnome-a3a19d91beb361f24d0f37201106f0a7fa638c21.tar.zst
freebsd-ports-gnome-a3a19d91beb361f24d0f37201106f0a7fa638c21.zip
Hm...seems the broken-ness is confined to 4-current now.
sampling.c: In function `UnitCirclePoint': sampling.c:116: syntax error before `/' sampling.c:116: warning: integer overflow in expression sampling.c:116: syntax error before `)' sampling.c:118: syntax error before `/' sampling.c:118: warning: integer overflow in expression sampling.c:118: syntax error before `)' sampling.c:122: syntax error before `/' sampling.c:122: warning: integer overflow in expression sampling.c:122: syntax error before `)' sampling.c:123: syntax error before `/' sampling.c:123: warning: integer overflow in expression sampling.c:123: syntax error before `)' *** Error code 1
Diffstat (limited to 'graphics/rayshade')
-rw-r--r--graphics/rayshade/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/graphics/rayshade/Makefile b/graphics/rayshade/Makefile
index 6665af5ecdd0..45e91fca6de4 100644
--- a/graphics/rayshade/Makefile
+++ b/graphics/rayshade/Makefile
@@ -17,8 +17,11 @@ MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= $(LOCALBASE)/lib/librle.a:${PORTSDIR}/graphics/urt
-BROKEN_ELF= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 400000
BROKEN= build
+.endif
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
@@ -40,4 +43,4 @@ do-install:
$(MKDIR) $(PREFIX)/share/examples/rayshade
$(INSTALL_DATA) $(WRKSRC)/Examples/* $(PREFIX)/share/examples/rayshade
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>