aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/recmpeg
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-02-02 21:07:45 +0800
committernork <nork@FreeBSD.org>2003-02-02 21:07:45 +0800
commit9461b260c2dde1238525276104cb10b32669965b (patch)
tree0377e7d911dee445b6ca578446ab8156527c9a2e /graphics/recmpeg
parentc55e1c7bf6df13fc900a1632970a46252bc5ebe9 (diff)
downloadfreebsd-ports-gnome-9461b260c2dde1238525276104cb10b32669965b.tar.gz
freebsd-ports-gnome-9461b260c2dde1238525276104cb10b32669965b.tar.zst
freebsd-ports-gnome-9461b260c2dde1238525276104cb10b32669965b.zip
Conditionalize gnugetopt dependencies.
PR: ports/47325 Submitted by: Ports Fury
Diffstat (limited to 'graphics/recmpeg')
-rw-r--r--graphics/recmpeg/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/graphics/recmpeg/Makefile b/graphics/recmpeg/Makefile
index b26843f659b8..2ba6dedd6605 100644
--- a/graphics/recmpeg/Makefile
+++ b/graphics/recmpeg/Makefile
@@ -14,13 +14,19 @@ MASTER_SITE_SUBDIR= fame
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
- fame-0.9.0:${PORTSDIR}/graphics/libfame
+LIB_DEPENDS= fame-0.9.0:${PORTSDIR}/graphics/libfame
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= recmpeg.1
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+.if !exists(/usr/include/getopt.h)
+LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LDFLAGS+= -lgnugetopt
+.endif
+
.include <bsd.port.mk>