aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/robot
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-18 05:27:07 +0800
committermaho <maho@FreeBSD.org>2007-01-18 05:27:07 +0800
commit6336d9cdba663e524bdc03a0d3253f5f32f46fcc (patch)
tree9a10b0a2d566564025370276e0b72c61db45f680 /graphics/robot
parent8b3a8b39f39652bec01b2f64dfe4cb6443a214f5 (diff)
downloadfreebsd-ports-gnome-6336d9cdba663e524bdc03a0d3253f5f32f46fcc.tar.gz
freebsd-ports-gnome-6336d9cdba663e524bdc03a0d3253f5f32f46fcc.tar.zst
freebsd-ports-gnome-6336d9cdba663e524bdc03a0d3253f5f32f46fcc.zip
* Migrate to gfortran.
* Bump port revision.
Diffstat (limited to 'graphics/robot')
-rw-r--r--graphics/robot/Makefile10
-rw-r--r--graphics/robot/files/patch-ARK+ARKfort.f11
-rw-r--r--graphics/robot/files/patch-Fitsio+Makefile20
-rw-r--r--graphics/robot/files/patch-Robot+Makefile8
-rw-r--r--graphics/robot/files/patch-Robot+subroutines.f11
5 files changed, 54 insertions, 6 deletions
diff --git a/graphics/robot/Makefile b/graphics/robot/Makefile
index 6f1bf2d13e49..7c3f1e60c4b3 100644
--- a/graphics/robot/Makefile
+++ b/graphics/robot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= robot
PORTVERSION= 4.93.89
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= ftp://lheaftp.gsfc.nasa.gov/pub/corbet/robot/
DISTNAME= robot-beta
@@ -21,7 +21,13 @@ LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
USE_X_PREFIX= yes
USE_GMAKE= yes
MAKE_ENV+= OPENWINHOME=${X11BASE}
-WEB_BROWSER?= mozilla
+WEB_BROWSER?= firefox
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+FFLAGS+= -ffixed-line-length-80
+MAKE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
MANL= robot.l
diff --git a/graphics/robot/files/patch-ARK+ARKfort.f b/graphics/robot/files/patch-ARK+ARKfort.f
new file mode 100644
index 000000000000..5661ed36c74c
--- /dev/null
+++ b/graphics/robot/files/patch-ARK+ARKfort.f
@@ -0,0 +1,11 @@
+--- ARK/ARKfort.f~ Wed May 4 00:14:51 2005
++++ ARK/ARKfort.f Wed Jan 17 18:01:35 2007
+@@ -998,7 +998,7 @@
+ character*(10) startext
+ integer nway, nchar
+ logical hase
+- integer i, epos, fnn, len, ic
++ integer i, epos, fnn, len, ic, add
+
+ integer ie, ibigE, ispace
+
diff --git a/graphics/robot/files/patch-Fitsio+Makefile b/graphics/robot/files/patch-Fitsio+Makefile
new file mode 100644
index 000000000000..1198bc6ebdbc
--- /dev/null
+++ b/graphics/robot/files/patch-Fitsio+Makefile
@@ -0,0 +1,20 @@
+--- Fitsio/Makefile Thu Jan 18 06:24:27 2007
++++ Fitsio/Makefile Thu Jan 18 06:24:17 2007
+@@ -24,7 +24,7 @@
+ # default: FC=f77
+ # Cray supercomputers: FC=cf77
+ #
+-FC=f77
++#FC=f77
+ #FC=f77
+ #
+ # 3. DEFINE COMPILER FLAGS:
+@@ -35,7 +35,7 @@
+ # IBM AIX xlf Fortran: FFLAGS= -O -u -qcharlen=2880
+ # HP-UX series: FFLAGS= -O -u +E5 +U77
+ #
+-FFLAGS=-O -u
++#FFLAGS=-O -u
+ #
+ # 4. DEFINE RANLIB (some machines don't use RANLIB so set it equal to 'touch')
+ #------------------
diff --git a/graphics/robot/files/patch-Robot+Makefile b/graphics/robot/files/patch-Robot+Makefile
index b38b35feb84e..7a06af59c709 100644
--- a/graphics/robot/files/patch-Robot+Makefile
+++ b/graphics/robot/files/patch-Robot+Makefile
@@ -1,5 +1,5 @@
---- Robot/Makefile.orig Tue May 3 17:14:51 2005
-+++ Robot/Makefile Wed Dec 28 16:58:22 2005
+--- Robot/Makefile.orig Wed May 4 00:14:51 2005
++++ Robot/Makefile Wed Jan 17 17:09:08 2007
@@ -15,7 +15,7 @@
@@ -21,10 +21,10 @@
# define compilers
#CC = cc
-CC = gcc
-+CC ?= gcc
++#CC ?= gcc
#FC = g77
-FC = f77
-+FC ?= f77
++#FC ?= f77
# define compile options here if required,
# e.g. debug
- CFLAGS = -g -Wall
diff --git a/graphics/robot/files/patch-Robot+subroutines.f b/graphics/robot/files/patch-Robot+subroutines.f
new file mode 100644
index 000000000000..c3af831ce228
--- /dev/null
+++ b/graphics/robot/files/patch-Robot+subroutines.f
@@ -0,0 +1,11 @@
+--- Robot/subroutines.f~ Wed May 4 00:14:51 2005
++++ Robot/subroutines.f Wed Jan 17 17:55:55 2007
+@@ -760,7 +760,7 @@
+ if(nharm .lt. 0)then
+ write(tstring, *)hharm, ' harmonics specified'
+ call xtext(tstring)
+- call xtext('Doesn\'t make sense so doing no summing')
++ call xtext('Does not make sense so doing no summing')
+ return
+ end if
+