aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ruby-esmart
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2008-04-06 16:58:21 +0800
committerstas <stas@FreeBSD.org>2008-04-06 16:58:21 +0800
commit6fbde8aaf51fc0bcaf991519b739b0592c98f740 (patch)
tree280ebf175af2693f172cb9dc5674fa73fb5992d3 /graphics/ruby-esmart
parentf29755f74021d623e3671b29c948ead5c3e33715 (diff)
downloadfreebsd-ports-gnome-6fbde8aaf51fc0bcaf991519b739b0592c98f740.tar.gz
freebsd-ports-gnome-6fbde8aaf51fc0bcaf991519b739b0592c98f740.tar.zst
freebsd-ports-gnome-6fbde8aaf51fc0bcaf991519b739b0592c98f740.zip
- Add ruby 1.9 support
- Implement new knobs for gems and rake (these are included in ruby 1.9 distribution already). Also move gem bits from ruby-gems/Makefile.common to bsd.ruby.mk[1]. Now to depend on gems or rake you should define USE_RUBYGEMS/USE_RAKE accordingly. Also RAKE_BIN variable is provided for pointing to the right rake executable. - Rewrite RUBY_SCHEBANG in awk to eliminate build dependency on ruby. Discussed with: Jonathan Weiss <jw@innerewut.de> [1] (gems maintainer) Tested by: ports@
Diffstat (limited to 'graphics/ruby-esmart')
-rw-r--r--graphics/ruby-esmart/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/graphics/ruby-esmart/Makefile b/graphics/ruby-esmart/Makefile
index f967e7f3728b..561178c18756 100644
--- a/graphics/ruby-esmart/Makefile
+++ b/graphics/ruby-esmart/Makefile
@@ -16,14 +16,13 @@ DISTNAME= ruby-esmart-${PORTVERSION}
MAINTAINER= stas@FreeBSD.org
COMMENT= Ruby bindings for Esmart library
-BUILD_DEPENDS= ${LOCALBASE}/bin/rake:${PORTSDIR}/devel/rubygem-rake \
- ${RUBY_SA}/evas/rb_evas.h:${PORTSDIR}/graphics/ruby-evas \
+BUILD_DEPENDS= ${RUBY_SA}/evas/rb_evas.h:${PORTSDIR}/graphics/ruby-evas \
${RUBY_SA}/ecore/rb_window.h:${PORTSDIR}/devel/ruby-ecore
USE_BZIP2= yes
USE_RUBY= yes
+USE_RAKE= yes
USE_EFL_ESMART= trans_x11 container draggies
-
CFLAGS+= -I"${LOCALBASE}/include" -fPIC
RUBY_SA= ${RUBY_SITEARCHLIBDIR}
@@ -32,10 +31,10 @@ RUBY_SA= ${RUBY_SITEARCHLIBDIR}
do-build:
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ESMART_PREFIX=${LOCALBASE} \
- ${LOCALBASE}/bin/rake)
+ ${RAKE_BIN})
do-install:
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ESMART_PREFIX=${LOCALBASE} \
- ${LOCALBASE}/bin/rake install)
+ ${RAKE_BIN} install)
.include <bsd.port.post.mk>