aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ruby-esmart
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2008-03-12 05:13:53 +0800
committerstas <stas@FreeBSD.org>2008-03-12 05:13:53 +0800
commit7843035eea9d002a1991cf57b8c8c617c6f55b1f (patch)
tree5c186a065f2ed99e4bc9b28ae52aa862ee51b8e9 /graphics/ruby-esmart
parent5ca76f49f1219351516746abab31c1305b88f628 (diff)
downloadfreebsd-ports-gnome-7843035eea9d002a1991cf57b8c8c617c6f55b1f.tar.gz
freebsd-ports-gnome-7843035eea9d002a1991cf57b8c8c617c6f55b1f.tar.zst
freebsd-ports-gnome-7843035eea9d002a1991cf57b8c8c617c6f55b1f.zip
- Update enlightenment-devel and EFL libraries to the latest snapshot
- Deprecate old unsupported apps and modules (entice, devian, eveil, engage) - Split evas and ecore to separate modules to handle dependencies properly - Disable PAM in enlightenment-devel as it don't work anyway (requires root privilegies) - Add DBUS support. Thanks to: az
Diffstat (limited to 'graphics/ruby-esmart')
-rw-r--r--graphics/ruby-esmart/Makefile14
-rw-r--r--graphics/ruby-esmart/distinfo6
-rw-r--r--graphics/ruby-esmart/pkg-plist1
3 files changed, 11 insertions, 10 deletions
diff --git a/graphics/ruby-esmart/Makefile b/graphics/ruby-esmart/Makefile
index aba6c904c731..f967e7f3728b 100644
--- a/graphics/ruby-esmart/Makefile
+++ b/graphics/ruby-esmart/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= esmart
-PORTVERSION= 20061008
-PORTREVISION= 1
+PORTVERSION= 20080302
+PORTREVISION= 0
CATEGORIES= graphics ruby
-MASTER_SITES= http://sunner.elcomnet.ru/~stas/
+MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-esmart-${PORTVERSION}
@@ -22,18 +22,20 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/rake:${PORTSDIR}/devel/rubygem-rake \
USE_BZIP2= yes
USE_RUBY= yes
-USE_EFL_ESMART= trans_x11
+USE_EFL_ESMART= trans_x11 container draggies
+
+CFLAGS+= -I"${LOCALBASE}/include" -fPIC
RUBY_SA= ${RUBY_SITEARCHLIBDIR}
.include <bsd.port.pre.mk>
do-build:
- @(cd ${WRKSRC}; ${SETENV} ESMART_PREFIX=${LOCALBASE} \
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ESMART_PREFIX=${LOCALBASE} \
${LOCALBASE}/bin/rake)
do-install:
- @(cd ${WRKSRC}; ${SETENV} ESMART_PREFIX=${LOCALBASE} \
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ESMART_PREFIX=${LOCALBASE} \
${LOCALBASE}/bin/rake install)
.include <bsd.port.post.mk>
diff --git a/graphics/ruby-esmart/distinfo b/graphics/ruby-esmart/distinfo
index fcfdb9fd8f4d..66a19381a807 100644
--- a/graphics/ruby-esmart/distinfo
+++ b/graphics/ruby-esmart/distinfo
@@ -1,3 +1,3 @@
-MD5 (ruby-esmart-20061008.tar.bz2) = 61cdc7b6594805247efaee74e3577886
-SHA256 (ruby-esmart-20061008.tar.bz2) = 276cd71d194c8c6a6825f56ce00aaaf62355fa838a3c1ecbdb31caef1890a69f
-SIZE (ruby-esmart-20061008.tar.bz2) = 13383
+MD5 (ruby-esmart-20080302.tar.bz2) = de09151f10b36539ed69bdb5a593ee78
+SHA256 (ruby-esmart-20080302.tar.bz2) = 66a6b878e225d49d96526f5b8e35a37e5c6ede32f65258024f1ca8c2489ab3b0
+SIZE (ruby-esmart-20080302.tar.bz2) = 17444
diff --git a/graphics/ruby-esmart/pkg-plist b/graphics/ruby-esmart/pkg-plist
index 1abe031152be..6f341dcb3a0b 100644
--- a/graphics/ruby-esmart/pkg-plist
+++ b/graphics/ruby-esmart/pkg-plist
@@ -2,4 +2,3 @@
%%RUBY_SITEARCHLIBDIR%%/esmart_container.so
%%RUBY_SITEARCHLIBDIR%%/esmart_draggies.so
%%RUBY_SITEARCHLIBDIR%%/esmart_trans_x11.so
-%%RUBY_SITEARCHLIBDIR%%/esmart_file_dialog.so