aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ruby-gd
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2013-11-27 13:58:14 +0800
committerdinoex <dinoex@FreeBSD.org>2013-11-27 13:58:14 +0800
commit4b4645972f433b5ff2d9e3b28a1db0d28c95ac34 (patch)
tree81e4158aa2cbafb37ebc341aefa21e93fc948497 /graphics/ruby-gd
parent159c163062b511a200ff53a9f35490aff5b2c4a9 (diff)
downloadfreebsd-ports-gnome-4b4645972f433b5ff2d9e3b28a1db0d28c95ac34.tar.gz
freebsd-ports-gnome-4b4645972f433b5ff2d9e3b28a1db0d28c95ac34.tar.zst
freebsd-ports-gnome-4b4645972f433b5ff2d9e3b28a1db0d28c95ac34.zip
- use STAGEDIR
Diffstat (limited to 'graphics/ruby-gd')
-rw-r--r--graphics/ruby-gd/Makefile26
1 files changed, 13 insertions, 13 deletions
diff --git a/graphics/ruby-gd/Makefile b/graphics/ruby-gd/Makefile
index b4dbbca6d35d..8b6e3dd65fc7 100644
--- a/graphics/ruby-gd/Makefile
+++ b/graphics/ruby-gd/Makefile
@@ -16,7 +16,7 @@ COMMENT= Ruby extension library to use Thomas Boutell's gd library
LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
-NO_STAGE= yes
+NEED_ROOT= yes
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
@@ -33,7 +33,7 @@ CONFIGURE_ARGS+= --enable-gd2_0 \
--with-gd-include="${LOCALBASE}/include"
LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
# Hmm, GREP and TRUE seem to be defined in the bsd.port.post.mk stage.
.if exists(${LOCALBASE}/bin/gd2topng)
@@ -66,20 +66,20 @@ post-patch:
${RUBY} -i -pe 'sub %r:%%GD%%:, "gd"' ${WRKSRC}/extconf.rb
post-install:
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
-.for f in ${EXAMPLES_EN}
- ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${RUBY_MODEXAMPLESDIR}/
-.endfor
-.endif
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODDOCDIR}/ja
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}/ja
.for f in ${DOCS_EN}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}/
.endfor
.for f in ${DOCS_JA}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}/ja/
+.endfor
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}
+.for f in ${EXAMPLES_EN}
+ ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
d>thierry2006-10-013-23/+22 * - Fix build with gcc 4.1miwi2006-09-301-1/+1 * - Fix build with gcc 4.1miwi2006-09-302-1/+11 * - Fix build with gcc4.1miwi2006-09-301-0/+4 * - Fix build with gcc4.1miwi2006-09-301-0/+1 * - Fix build with gcc4.1miwi2006-09-301-1/+7 * - Fix compile time errorsmiwi2006-09-301-3/+4 * - Update to 0.0.21rafan2006-09-293-15/+155 * - Chase devel/guichan 0.5.0 updaterafan2006-09-293-1/+47 * - Update the distinfo file. One file was rerolled because it needs a serveracm2006-09-292-3/+4 * - Update to 4.2.21 (should work on ia64)johans2006-09-286-153/+26 * - Fix build with gcc41 (error noted by pointyhat)johans2006-09-281-2/+8 * - Update to 3.2.2miwi2006-09-283-5/+9 * - Fix the long description of nvidia optionacm2006-09-281-1/+1 * mark IGNORE again for OSVERSION < 600000oliver2006-09-271-3/+3 * Update to scare-1.3.4 - *all* the source files were reindented withroam2006-09-275-56/+62 * - Fix pkg-plistacm2006-09-272-1/+2 * - Update to 7.2.5rafan2006-09-262-4/+4 * - Fix a security bugsat2006-09-263-1/+23 * The Mud Magic Mud Client is written in GTK+ and supports MXP, MSP,pav2006-09-265-0/+161 * - Fix build on 4.xrafan2006-09-251-1/+1 * - Update to version 0.55.alepulver2006-09-2513-540/+15 * Upgrade to 0.8.7barved2006-09-242-5/+4 * Update to 1.0.1arved2006-09-244-35/+7 * - Unbrokestas2006-09-243-35/+52 * Release my ports back into the wild.adamw2006-09-243-3/+3 * - Fix build on some archs by not using -march=$ARCHsat2006-09-241-0/+2 * - Update to 0.3.016acm2006-09-233-4/+7 * - Fix installation problemacm2006-09-232-8/+4 * - Update to version 2.1danfe2006-09-224-22/+20 * - Update to 0.2.1clsung2006-09-225-12/+49 * - Fix SDL-dependent ports broken by last update.stas2006-09-211-1/+2 * - Fix the linux-savage script. Now it uses silverback instead of savageacm2006-09-202-2/+17 * - Update devel/sdl12 to version 1.2.11. Now we employ stock SDL directorystas2006-09-20254-614/+424 * - No need to use bsdtar on 4.x anymorerafan2006-09-191-12/+5 * - Add a note in pkg-message about the High Resolution Pack available atalepulver2006-09-191-0/+2