aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ruby-libpng
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-12-07 01:17:38 +0800
committerknu <knu@FreeBSD.org>2002-12-07 01:17:38 +0800
commit9c46f078394d114e50ad01ff921a88b74dda7eb1 (patch)
tree4810246f6e2ebdc6787c76cd4552ffabb88ae682 /graphics/ruby-libpng
parent1900d9b4804ade641a7bbef2252af134e5f2ba8f (diff)
downloadfreebsd-ports-gnome-9c46f078394d114e50ad01ff921a88b74dda7eb1.tar.gz
freebsd-ports-gnome-9c46f078394d114e50ad01ff921a88b74dda7eb1.tar.zst
freebsd-ports-gnome-9c46f078394d114e50ad01ff921a88b74dda7eb1.zip
Introduce a knob RUBY_NO_RD_HTML and enable it by default on alpha. This
replaces the non-working NOPORTDOCS workaround and fixes build on the alpha, where rd2 coredumps. Tested on: the axp cluster Approved by: kris
Diffstat (limited to 'graphics/ruby-libpng')
-rw-r--r--graphics/ruby-libpng/Makefile19
-rw-r--r--graphics/ruby-libpng/pkg-plist2
2 files changed, 10 insertions, 11 deletions
diff --git a/graphics/ruby-libpng/Makefile b/graphics/ruby-libpng/Makefile
index 285a51d6bfad..45f699ae638b 100644
--- a/graphics/ruby-libpng/Makefile
+++ b/graphics/ruby-libpng/Makefile
@@ -22,23 +22,24 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-USE_RUBY_RDTOOL= yes
INSTALL_TARGET= site-install
-DOCS_JA= readme.ja.html readme.ja.rd readme.ja.txt
+RUBY_RD_FILES= readme.ja.rd
+
+DOCS_JA= readme.ja.txt \
+ ${RUBY_RD_FILES} \
+ ${RUBY_RD_HTML_FILES}
EXAMPLES_EN= es.png png.rb pngtest.rb pngtest.sh \
sample/0.png sample/1.png sample/2.png sample/3.png \
sample/4.png sample/5.png sample/6.png sample/7.png \
sample/8.png sample/9.png sample/pngcat.rb
-.if !defined(NOPORTDOCS)
-post-build:
- @cd ${WRKSRC}; \
- ${RUBY_RD2} readme.ja.rd > readme.ja.html
-.endif
+post-install: doc-install
-post-install:
+.include <bsd.port.mk>
+
+doc-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
.for f in ${EXAMPLES_EN}
@@ -49,5 +50,3 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
.endfor
.endif
-
-.include <bsd.port.mk>
diff --git a/graphics/ruby-libpng/pkg-plist b/graphics/ruby-libpng/pkg-plist
index 66bc90e9ab12..3ddabeb36bb4 100644
--- a/graphics/ruby-libpng/pkg-plist
+++ b/graphics/ruby-libpng/pkg-plist
@@ -15,7 +15,7 @@
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/9.png
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/pngcat.rb
%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/readme.ja.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/ja/readme.ja.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/readme.ja.rd
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/readme.ja.txt
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/ja