aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/s10sh
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
committerstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
commit08bfa7c4aa027efa35afd531304e476e4f713b80 (patch)
tree31b7120f0eb5ff46ed252641018a5ff19ff41fc3 /graphics/s10sh
parent982434000a36499258eff52f7032254355edca7a (diff)
downloadfreebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.gz
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.zst
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.zip
- Chase libusb20 rename in r189585.
- Mark sane-backends broken on current due to changes in USB stack. Reviewed by: thompsa (old version), miwi Tested by: miwi
Diffstat (limited to 'graphics/s10sh')
-rw-r--r--graphics/s10sh/Makefile14
-rw-r--r--graphics/s10sh/files/Makefile.bsd4
2 files changed, 12 insertions, 6 deletions
diff --git a/graphics/s10sh/Makefile b/graphics/s10sh/Makefile
index 3aed416d77d7..0ea05615bb5a 100644
--- a/graphics/s10sh/Makefile
+++ b/graphics/s10sh/Makefile
@@ -14,12 +14,6 @@ MASTER_SITES= http://www.reynoldsnet.org/s10sh/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= USB/serial userspace driver for the Canon PowerShot digital cameras
-.if defined(NOUSB) || defined(WITHOUT_USB)
-MAKE_ENV+= WITHOUT_USB=YES
-.else
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
-.endif
-
# Don't extract the libusb bundled with s10sh:
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude '*/libusb*'
@@ -27,6 +21,14 @@ MAKEFILE= ${FILESDIR}/Makefile.bsd
.include <bsd.port.pre.mk>
+.if defined(NOUSB) || defined(WITHOUT_USB)
+MAKE_ENV+= WITHOUT_USB=YES
+.else
+. if ${OSVERSION} < 800069
+LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
+. endif
+.endif
+
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
diff --git a/graphics/s10sh/files/Makefile.bsd b/graphics/s10sh/files/Makefile.bsd
index d9b2f58516e2..8abbf4eb98b8 100644
--- a/graphics/s10sh/files/Makefile.bsd
+++ b/graphics/s10sh/files/Makefile.bsd
@@ -7,10 +7,14 @@ LDADD += -lreadline -ltermcap
CFLAGS += -DHAVE_READLINE
.if !defined(WITHOUT_USB)
+. if ${OSVERSION} < 800069
USBLIB != ${LOCALBASE}/bin/libusb-config --libs
LDADD += ${USBLIB}
USBCF != ${LOCALBASE}/bin/libusb-config --cflags
CFLAGS += ${USBCF} -DHAVE_USB_SUPPORT
+. else
+LDADD += -lusb
+. endif
SRCS += usb.c
.endif