aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/sage/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-02-06 05:47:23 +0800
committerpav <pav@FreeBSD.org>2005-02-06 05:47:23 +0800
commit1fd8caef06e8d758d114d9dac8790b70f3f32bdd (patch)
tree9925da5b32727d74f2451714e002984b737de2d2 /graphics/sage/Makefile
parent93f2909a13532a1131d11ca194250e4c0fda65fb (diff)
downloadfreebsd-ports-gnome-1fd8caef06e8d758d114d9dac8790b70f3f32bdd.tar.gz
freebsd-ports-gnome-1fd8caef06e8d758d114d9dac8790b70f3f32bdd.tar.zst
freebsd-ports-gnome-1fd8caef06e8d758d114d9dac8790b70f3f32bdd.zip
Sage is an OpenGL extension library written to make use of SDL's mechanism for
enabling OpenGL's extensions. PR: ports/77088 Submitted by: Jan Rochel <jannisan@t-online.de>
Diffstat (limited to 'graphics/sage/Makefile')
-rw-r--r--graphics/sage/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/graphics/sage/Makefile b/graphics/sage/Makefile
new file mode 100644
index 000000000000..26010206f384
--- /dev/null
+++ b/graphics/sage/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: sage
+# Date created: 4 February 2005
+# Whom: Janni
+#
+# $FreeBSD$
+#
+
+PORTNAME= sage
+PORTVERSION= 0.1.1
+CATEGORIES= graphics devel
+MASTER_SITES= ftp://ftp.worldforge.org/pub/worldforge/libs/sage/ \
+ http://purple.worldforge.org/downloads/libs/sage/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= worldforge
+
+MAINTAINER= jannisan@t-online.de
+COMMENT= OpenGL extension library
+
+USE_SDL= sdl
+USE_GL= yes
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+CFLAGS= -I${X11BASE}/include
+CONFIGURE_ENV= "CFLAGS=${CFLAGS}"
+
+post-patch:
+ ${REINPLACE_CMD} s/sdl-config/sdl11-config/g ${WRKSRC}/configure
+
+.include <bsd.port.mk>