aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/sane-backends
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-10-16 22:59:26 +0800
committermakc <makc@FreeBSD.org>2010-10-16 22:59:26 +0800
commit0b16fe98b9f085b421400128726bebc28ace4e77 (patch)
tree5d41db7fd5502c3a5450c369d6253f19c178db25 /graphics/sane-backends
parentf37c76f3e4c1f5e2e3acf336483378245cb40a40 (diff)
downloadfreebsd-ports-gnome-0b16fe98b9f085b421400128726bebc28ace4e77.tar.gz
freebsd-ports-gnome-0b16fe98b9f085b421400128726bebc28ace4e77.tar.zst
freebsd-ports-gnome-0b16fe98b9f085b421400128726bebc28ace4e77.zip
Enable pthread to unbreak scanning with saned + hpaio
while here, fix build with NOPORTDOCS PR: based on ports/151157 Submitted by: Marcin Wisnicki <mwisnicki+freebsd at gmail.com>
Diffstat (limited to 'graphics/sane-backends')
-rw-r--r--graphics/sane-backends/Makefile12
-rw-r--r--graphics/sane-backends/Makefile.man1
-rw-r--r--graphics/sane-backends/pkg-plist3
3 files changed, 12 insertions, 4 deletions
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index 06898e8bfe6b..a9537650b771 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sane-backends
PORTVERSION= 1.0.21
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://alioth.debian.org/frs/download.php/3258/ \
ftp://ftp.sane-project.org/pub/sane/%SUBDIR%/ \
@@ -33,11 +33,11 @@ OPTIONS= USB "USB support" on \
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --with-docdir=${DOCSDIR} \
--disable-latex \
- --disable-locking
-MAKE_ENV= NOPORTDOCS="${NOPORTDOCS}"
+ --disable-locking \
+ --enable-pthread
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
@@ -50,6 +50,10 @@ GROUPS= saned
.include "Makefile.man"
.include <bsd.port.pre.mk>
+.if defined(NOPORTDOCS)
+MAKE_ENV= NOPORTDOCS=1
+.endif
+
.if defined(WITHOUT_USB)
CONFIGURE_ARGS+= --disable-libusb
.else
diff --git a/graphics/sane-backends/Makefile.man b/graphics/sane-backends/Makefile.man
index 1bc1df0d8fa8..faf1a80f3fa5 100644
--- a/graphics/sane-backends/Makefile.man
+++ b/graphics/sane-backends/Makefile.man
@@ -47,6 +47,7 @@ MAN5+= sane-microtek.5
MAN5+= sane-microtek2.5
MAN5+= sane-mustek.5
MAN5+= sane-mustek_usb.5
+MAN5+= sane-mustek_usb2.5
MAN5+= sane-nec.5
MAN5+= sane-net.5
MAN5+= sane-niash.5
diff --git a/graphics/sane-backends/pkg-plist b/graphics/sane-backends/pkg-plist
index db137ad5cb51..580c2027c5ea 100644
--- a/graphics/sane-backends/pkg-plist
+++ b/graphics/sane-backends/pkg-plist
@@ -304,6 +304,9 @@ lib/sane/libsane-mustek.so.1
lib/sane/libsane-mustek_usb.la
lib/sane/libsane-mustek_usb.so
lib/sane/libsane-mustek_usb.so.1
+lib/sane/libsane-mustek_usb2.la
+lib/sane/libsane-mustek_usb2.so
+lib/sane/libsane-mustek_usb2.so.1
lib/sane/libsane-nec.la
lib/sane/libsane-nec.so
lib/sane/libsane-nec.so.1