aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/sane/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-05-29 11:56:15 +0800
committersteve <steve@FreeBSD.org>1999-05-29 11:56:15 +0800
commitff2c6bac0ded6793103b12ed47ec261ee75b026f (patch)
tree5d44c4203ffb617246e3922b0cbae09608e0e203 /graphics/sane/Makefile
parent09dcfd52af329c174b5aedbac6986cf817fe17d5 (diff)
downloadfreebsd-ports-gnome-ff2c6bac0ded6793103b12ed47ec261ee75b026f.tar.gz
freebsd-ports-gnome-ff2c6bac0ded6793103b12ed47ec261ee75b026f.tar.zst
freebsd-ports-gnome-ff2c6bac0ded6793103b12ed47ec261ee75b026f.zip
Update to use gtk version 1.2.3.
PR: 11842 Submitted by: Jeremy Lea <reg@shale.csir.co.za>
Diffstat (limited to 'graphics/sane/Makefile')
-rw-r--r--graphics/sane/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/graphics/sane/Makefile b/graphics/sane/Makefile
index 0bb3213a11f3..50bce21f3ad3 100644
--- a/graphics/sane/Makefile
+++ b/graphics/sane/Makefile
@@ -1,9 +1,9 @@
# New ports collection makefile for: sane
-# Version required: 1.00
+# Version required: 1.0.1
# Date created: Sat Jul 19 16:23:10 MET DST 1997
# Whom: gary@hotlava.com
#
-# $Id: Makefile,v 1.15 1999/04/07 19:10:45 fenner Exp $
+# $Id: Makefile,v 1.16 1999/05/22 04:36:03 obrien Exp $
#
DISTNAME= sane-1.0.1
@@ -13,9 +13,11 @@ MASTER_SITES= ftp://ftp.mostang.com/pub/sane/ \
MAINTAINER= gary@hotlava.com
-LIB_DEPENDS= gtk12.1:${PORTSDIR}/x11-toolkits/gtk12 \
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
jpeg.9:${PORTSDIR}/graphics/jpeg
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
.include <bsd.port.pre.mk>
USE_GMAKE= yes
@@ -23,11 +25,11 @@ GNU_CONFIGURE= yes
.if ${OSVERSION} < 300000
CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib" \
- GTK_CONFIG="${X11BASE}/bin/gtk12-config"
+ GTK_CONFIG="${GTK_CONFIG}"
.else
CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lcam" \
- GTK_CONFIG="${X11BASE}/bin/gtk12-config"
+ GTK_CONFIG="${GTK_CONFIG}"
.endif
MAN1= scanimage.1 \
@@ -58,7 +60,6 @@ pre-configure:
@${ECHO} "*** the GIMP and GTK packages/ports."
post-install:
- ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
@${CAT} ${PKGDIR}/MESSAGE
.include <bsd.port.post.mk>