aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/scale2x
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-03-29 23:59:37 +0800
committerdinoex <dinoex@FreeBSD.org>2010-03-29 23:59:37 +0800
commitff504284f0938127a901e14984752598a17f47bf (patch)
tree3978690f990b130126f9dfbdf2ea3f22a5b18acb /graphics/scale2x
parent25e023b06dbd2619ab97157fb23487bc3407a4f2 (diff)
downloadfreebsd-ports-gnome-ff504284f0938127a901e14984752598a17f47bf.tar.gz
freebsd-ports-gnome-ff504284f0938127a901e14984752598a17f47bf.tar.zst
freebsd-ports-gnome-ff504284f0938127a901e14984752598a17f47bf.zip
- fix build for png-1.4.1
Diffstat (limited to 'graphics/scale2x')
-rw-r--r--graphics/scale2x/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/graphics/scale2x/Makefile b/graphics/scale2x/Makefile
index 70dcf03d68f6..c18aa25ca957 100644
--- a/graphics/scale2x/Makefile
+++ b/graphics/scale2x/Makefile
@@ -22,7 +22,11 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= scalex.1 scalerx.1
PLIST_FILES= bin/scalex bin/scalerx
-CPPFLAGS= `libpng12-config --I_opts`
-LDFLAGS= `libpng12-config --L_opts`
+CPPFLAGS= `libpng14-config --I_opts`
+LDFLAGS= `libpng14-config --L_opts`
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
+ ${WRKSRC}/file.c
.include <bsd.port.mk>