aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/sdl2_image
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2013-06-22 03:56:27 +0800
committermva <mva@FreeBSD.org>2013-06-22 03:56:27 +0800
commitca9e88f577e783e47f3270238d1f57adb749bf18 (patch)
tree16b6a36999fedc7fbad7af76e86d017a12040f78 /graphics/sdl2_image
parent03330a7fa2f520aae235ca03d5a8ac8ea716e7db (diff)
downloadfreebsd-ports-gnome-ca9e88f577e783e47f3270238d1f57adb749bf18.tar.gz
freebsd-ports-gnome-ca9e88f577e783e47f3270238d1f57adb749bf18.tar.zst
freebsd-ports-gnome-ca9e88f577e783e47f3270238d1f57adb749bf18.zip
Welcome SDL2 to the FreeBSD ports system!
A set of new SDL2 related ports has been added, which are essentially the same as their corresponding port for SDL1.2: audio/sdl2_mixer graphics/sdl2_image graphics/sdl2_ttf net/sdl2_net A set of new USE_SDL knobs is available to enable SDL2 and its related ports to be added as dependency to ports. Use either of USE_SDL= sdl2 image2 mixer2 net2 ttf2 to pull in the specific sdl2_* or sdl20 port.
Diffstat (limited to 'graphics/sdl2_image')
-rw-r--r--graphics/sdl2_image/Makefile27
-rw-r--r--graphics/sdl2_image/distinfo2
-rw-r--r--graphics/sdl2_image/pkg-descr18
-rw-r--r--graphics/sdl2_image/pkg-plist7
4 files changed, 54 insertions, 0 deletions
diff --git a/graphics/sdl2_image/Makefile b/graphics/sdl2_image/Makefile
new file mode 100644
index 000000000000..dcf2540238dc
--- /dev/null
+++ b/graphics/sdl2_image/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= sdl2_image
+PORTVERSION= 2.0.p1
+CATEGORIES= graphics
+MASTER_SITES= http://www.libsdl.org/tmp/SDL_image/release/
+DISTNAME= SDL2_image-2.0.0
+
+MAINTAINER= mva@FreeBSD.org
+COMMENT= A simple library to load images of various formats as SDL surfaces
+
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
+ png15:${PORTSDIR}/graphics/png \
+ tiff:${PORTSDIR}/graphics/tiff \
+ webp:${PORTSDIR}/graphics/webp
+
+USES= pkgconfig:build pathfix
+USE_AUTOTOOLS= libtool
+USE_SDL= sdl2
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lm
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/sdl2_image/distinfo b/graphics/sdl2_image/distinfo
new file mode 100644
index 000000000000..f0fa1a91ac37
--- /dev/null
+++ b/graphics/sdl2_image/distinfo
@@ -0,0 +1,2 @@
+SHA256 (SDL2_image-2.0.0.tar.gz) = 9c14ab164ac4a9d9afad6f76ca65da0021cfc0108b0152771ca19926b426ab33
+SIZE (SDL2_image-2.0.0.tar.gz) = 8397556
diff --git a/graphics/sdl2_image/pkg-descr b/graphics/sdl2_image/pkg-descr
new file mode 100644
index 000000000000..83855f2811c5
--- /dev/null
+++ b/graphics/sdl2_image/pkg-descr
@@ -0,0 +1,18 @@
+This is a simple library to load images of various formats as SDL surfaces.
+This library supports BMP, PPM, PCX, GIF, JPEG, PNG, TGA, and TIFF formats.
+
+API:
+#include "SDL_image.h"
+
+ SDL_Surface *IMG_Load(const char *file);
+or
+ SDL_Surface *IMG_Load_RW(SDL_RWops *src, int freesrc);
+or
+ SDL_Surface *IMG_Load_RW(SDL_RWops *src, int freesrc, char *type);
+
+where type is a string specifying the format (i.e. "PNG" or "pcx").
+Note that IMG_Load_RW cannot load TGA images.
+
+An example program 'showimage' is included, with source in showimage.c
+
+WWW: http://www.libsdl.org/projects/SDL_image/
diff --git a/graphics/sdl2_image/pkg-plist b/graphics/sdl2_image/pkg-plist
new file mode 100644
index 000000000000..6365ab58aaf3
--- /dev/null
+++ b/graphics/sdl2_image/pkg-plist
@@ -0,0 +1,7 @@
+include/SDL2/SDL_image.h
+lib/libSDL2_image-2.0.so
+lib/libSDL2_image-2.0.so.0
+lib/libSDL2_image.a
+lib/libSDL2_image.la
+lib/libSDL2_image.so
+libdata/pkgconfig/SDL2_image.pc