aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/seexpr
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-10-09 18:21:33 +0800
committerdanfe <danfe@FreeBSD.org>2015-10-09 18:21:33 +0800
commit5b8a61892be6c8b5413a756ce2648f3784bce9c7 (patch)
tree6f49aed51d876aac55e06abf4b358fee8ff06671 /graphics/seexpr
parent369084422db1ce9dc4d64f4c6e41cbf6257a95d9 (diff)
downloadfreebsd-ports-gnome-5b8a61892be6c8b5413a756ce2648f3784bce9c7.tar.gz
freebsd-ports-gnome-5b8a61892be6c8b5413a756ce2648f3784bce9c7.tar.zst
freebsd-ports-gnome-5b8a61892be6c8b5413a756ce2648f3784bce9c7.zip
Add a port of SeExpr, embeddable expression evaluation language from Walt
Disney Animation Studios. WWW: http://www.disneyanimation.com/technology/seexpr.html
Diffstat (limited to 'graphics/seexpr')
-rw-r--r--graphics/seexpr/Makefile42
-rw-r--r--graphics/seexpr/distinfo2
-rw-r--r--graphics/seexpr/pkg-descr13
-rw-r--r--graphics/seexpr/pkg-plist41
4 files changed, 98 insertions, 0 deletions
diff --git a/graphics/seexpr/Makefile b/graphics/seexpr/Makefile
new file mode 100644
index 000000000000..f9c72e77afb7
--- /dev/null
+++ b/graphics/seexpr/Makefile
@@ -0,0 +1,42 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= seexpr
+DISTVERSION= 1.0.1.2015.08.29
+CATEGORIES= graphics math
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Embeddable expression evaluation language
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= ${LOCALBASE}/share/py-sip/QtGui/QtGuimod.sip:${PORTSDIR}/x11-toolkits/py-qt4-gui
+
+USE_GITHUB= yes
+GH_ACCOUNT= wdas
+GH_TAGNAME= 36ffb818b8
+
+USES= bison cmake compiler:c++0x python
+USE_QT4= moc_build qmake_build rcc_build uic_build gui opengl
+
+WRKSRC= ${WRKDIR}/SeExpr-${GH_TAGNAME_EXTRACT}
+
+CXXFLAGS+= -I${LOCALBASE}/include
+
+.include <bsd.port.pre.mk>
+
+# base flex(1) v2.5.4 is not sufficient
+.if ${OSVERSION} < 1000033
+BUILD_DEPENDS+= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e '/<alloca\.h>/d' ${WRKSRC}/src/SeExpr/SePlatform.h
+ @${REINPLACE_CMD} -e 's, "dl",,' ${WRKSRC}/src/SeExpr/CMakeLists.txt
+ @${REINPLACE_CMD} -e '/tests/d' ${WRKSRC}/CMakeLists.txt
+.if ${OSVERSION} < 1000033
+ @${REINPLACE_CMD} -e '/COMMAND/s,flex,${LOCALBASE}/bin/&,' \
+ ${WRKSRC}/src/build/macros.cmake
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/seexpr/distinfo b/graphics/seexpr/distinfo
new file mode 100644
index 000000000000..125f0b64e03a
--- /dev/null
+++ b/graphics/seexpr/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wdas-seexpr-1.0.1.2015.08.29-36ffb818b8_GH0.tar.gz) = 8361adb26310060b063e37376625acb60314deac081130a397857f04884e2a7b
+SIZE (wdas-seexpr-1.0.1.2015.08.29-36ffb818b8_GH0.tar.gz) = 709489
diff --git a/graphics/seexpr/pkg-descr b/graphics/seexpr/pkg-descr
new file mode 100644
index 000000000000..57a3e4ca1ac2
--- /dev/null
+++ b/graphics/seexpr/pkg-descr
@@ -0,0 +1,13 @@
+SeExpr is simple expression language that provided artistic control and
+customization to your software. It can be used for procedural geometry
+synthesis, image synthesis, simulation control, and much more.
+
+Major features:
+
+ * Arithmetic expression of scalar/vector types
+ * Large library of built-in functions
+ * Extensible variables and functions (including with DSOs)
+ * Simple to embed in any program
+ * High-level UI components to manipulate and visualize expressions
+
+WWW: http://www.disneyanimation.com/technology/seexpr.html
diff --git a/graphics/seexpr/pkg-plist b/graphics/seexpr/pkg-plist
new file mode 100644
index 000000000000..9148ff94c59b
--- /dev/null
+++ b/graphics/seexpr/pkg-plist
@@ -0,0 +1,41 @@
+bin/asciiCalc
+bin/asciiGraph
+bin/imageEditor
+bin/imageSynth
+include/SeContext.h
+include/SeCurve.h
+include/SeExprBuiltins.h
+include/SeExprEditor/SeExprEdBrowser.h
+include/SeExprEditor/SeExprEdColorCurve.h
+include/SeExprEditor/SeExprEdColorSwatchWidget.h
+include/SeExprEditor/SeExprEdControl.h
+include/SeExprEditor/SeExprEdControlCollection.h
+include/SeExprEditor/SeExprEdCurve.h
+include/SeExprEditor/SeExprEdDialog.h
+include/SeExprEditor/SeExprEdFileDialog.h
+include/SeExprEditor/SeExprEdGrapher2d.h
+include/SeExprEditor/SeExprEdPopupDocumentation.h
+include/SeExprEditor/SeExprEdShortEdit.h
+include/SeExprEditor/SeExprEditor.h
+include/SeExprFunc.h
+include/SeExprMacros.h
+include/SeExprNode.h
+include/SeExprParser.h
+include/SeExpression.h
+include/SeMutex.h
+include/SeNoise.h
+include/SeNoiseTables.h
+include/SePlatform.h
+include/SeVec3d.h
+lib/libSeExpr.a
+lib/libSeExpr.so
+lib/libSeExprEditor.so
+%%PYTHON_SITELIBDIR%%/SeExpr/__init__.py
+%%PYTHON_SITELIBDIR%%/SeExpr/expreditor.so
+share/SeExpr/demo/segraph
+share/SeExpr/expressions/fbm.se
+share/SeExpr/expressions/noise.se
+share/SeExpr/expressions/noisecolor1.se
+share/SeExpr/expressions/noisecolor2.se
+share/SeExpr/expressions/raytrace.se
+share/SeExpr/expressions/sinc.se