aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/show
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-08-26 04:12:53 +0800
committerkrion <krion@FreeBSD.org>2003-08-26 04:12:53 +0800
commit8cc76e670a4dbf7ce14b697eec3812a0237757ec (patch)
tree1d4325593ecaa25b4d14754cc65a29de62dfeb93 /graphics/show
parent55658528d8b40a6a86a82b8cfa25012ad27224c6 (diff)
downloadfreebsd-ports-gnome-8cc76e670a4dbf7ce14b697eec3812a0237757ec.tar.gz
freebsd-ports-gnome-8cc76e670a4dbf7ce14b697eec3812a0237757ec.tar.zst
freebsd-ports-gnome-8cc76e670a4dbf7ce14b697eec3812a0237757ec.zip
Show is a fast, flexible, extensible, and bloat-free image
viewer for X11 that can fade images in, display them, and fade them out according to user-specified values of fade speed, fade type, and delay. It features an extremely small executable footprint, support for well over a dozen image formats, variable scaling, magnification, window positioning, clockwise and counterclockwise image rotation, X/Y axis flipping, over 200 different color transition modes, wildcard support, and logging abilities. It can also be easilly incorporated into multimedia presentations, shell scripts, and other utilities. WWW: http://freshmeat.net/projects/show/ PR: 54160 Submitted by: Roop Nanuwa <i6a2@ugrad.cs.ubc.ca>
Diffstat (limited to 'graphics/show')
-rw-r--r--graphics/show/Makefile28
-rw-r--r--graphics/show/distinfo1
-rw-r--r--graphics/show/pkg-descr13
-rw-r--r--graphics/show/pkg-plist1
4 files changed, 43 insertions, 0 deletions
diff --git a/graphics/show/Makefile b/graphics/show/Makefile
new file mode 100644
index 000000000000..a0ad7951a7cd
--- /dev/null
+++ b/graphics/show/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: show
+# Date created: 06 July 2003
+# Whom: roop
+#
+# $FreeBSD$
+#
+
+PORTNAME= show
+PORTVERSION= 2.1
+CATEGORIES= graphics
+MASTER_SITES= http://www.ugrad.cs.ubc.ca/~i6a2/show/
+
+MAINTAINER= i6a2@ugrad.cs.ubc.ca
+COMMENT= A fast, flexible, extensible and bloat-free image viewer for X11
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ ungif.5:${PORTSDIR}/graphics/libungif \
+ Imlib.5:${PORTSDIR}/graphics/imlib
+
+USE_XLIB= yes
+USE_X_PREFIX= yes
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/show ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/show/distinfo b/graphics/show/distinfo
new file mode 100644
index 000000000000..52328383621a
--- /dev/null
+++ b/graphics/show/distinfo
@@ -0,0 +1 @@
+MD5 (show-2.1.tar.gz) = 8219274c59cb0d5791c0d3bdb30f5879
diff --git a/graphics/show/pkg-descr b/graphics/show/pkg-descr
new file mode 100644
index 000000000000..19eda36e87ca
--- /dev/null
+++ b/graphics/show/pkg-descr
@@ -0,0 +1,13 @@
+Show is a fast, flexible, extensible, and bloat-free image viewer for X11 that
+can fade images in, display them, and fade them out according to user-specified
+values of fade speed, fade type, and delay. It features an extremely small
+executable footprint, support for well over a dozen image formats, variable
+scaling, magnification, window positioning, clockwise and counterclockwise
+image rotation, X/Y axis flipping, over 200 different color transition modes,
+wildcard support, and logging abilities. It can also be easilly incorporated
+into multimedia presentations, shell scripts, and other utilities.
+
+WWW: http://freshmeat.net/projects/show/
+
+- roop
+i6a2@ugrad.cs.ubc.ca
diff --git a/graphics/show/pkg-plist b/graphics/show/pkg-plist
new file mode 100644
index 000000000000..c2f882c0b9ff
--- /dev/null
+++ b/graphics/show/pkg-plist
@@ -0,0 +1 @@
+bin/show