aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/simpleviewer
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
committerdinoex <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
commit530706893f31269bbfa303e069f2e76cbbe2fce7 (patch)
treea8077a0d6e20d70b39e6a7fe3e57a6dafe7c7f33 /graphics/simpleviewer
parent9d262811a145d3e715edefd1d5d64ceac41de547 (diff)
downloadfreebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.tar.gz
freebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.tar.zst
freebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.zip
- update png to 1.5.10
Diffstat (limited to 'graphics/simpleviewer')
-rw-r--r--graphics/simpleviewer/Makefile7
-rw-r--r--graphics/simpleviewer/files/patch-formatpng.cpp10
2 files changed, 14 insertions, 3 deletions
diff --git a/graphics/simpleviewer/Makefile b/graphics/simpleviewer/Makefile
index fa97051b7410..9e02170f6af9 100644
--- a/graphics/simpleviewer/Makefile
+++ b/graphics/simpleviewer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= simpleviewer
PORTVERSION= 1.7.1553.8560
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/OpenGL%20edition
DISTNAME= sviewgl-src-${PORTVERSION}
@@ -18,13 +18,14 @@ COMMENT= Small and simple OpenGL image viewer with transparency support
LICENSE= GPLv2
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
gif.5:${PORTSDIR}/graphics/giflib
USE_BZIP2= yes
USE_EFL= imlib2
USE_GL= glut
WRKSRC= ${WRKDIR}/sviewgl-src
+CFLAGS+= -I${LOCALBASE}/include/libpng15
MAKE_ARGS= CC=${CXX}
PLIST_FILES= bin/sviewgl
@@ -32,7 +33,7 @@ PLIST_FILES= bin/sviewgl
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e 's,-O2,${CFLAGS}, ; s,/usr,${LOCALBASE},g ; \
+ @${REINPLACE_CMD} -e 's,-O2,${CFLAGS}, ; s,/usr/include,${LOCALBASE}/include,g ; \
s,=-s,=-L${LOCALBASE}/lib,' ${WRKSRC}/Makefile
.if ${OSVERSION} < 800501
@${REINPLACE_CMD} -e 's,const struct dirent,struct dirent,' \
diff --git a/graphics/simpleviewer/files/patch-formatpng.cpp b/graphics/simpleviewer/files/patch-formatpng.cpp
new file mode 100644
index 000000000000..b910eb4ffbf7
--- /dev/null
+++ b/graphics/simpleviewer/files/patch-formatpng.cpp
@@ -0,0 +1,10 @@
+--- src/formats/formatpng.cpp.orig 2010-08-29 16:33:33.000000000 +0200
++++ src/formats/formatpng.cpp 2012-05-05 07:46:22.000000000 +0200
+@@ -7,6 +7,7 @@
+
+ #include "formatpng.h"
+ #include <png.h>
++#include <pngpriv.h>
+ #include <string.h>
+ #include <iostream>
+