aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/smpeg/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-12-11 17:28:57 +0800
committersobomax <sobomax@FreeBSD.org>2000-12-11 17:28:57 +0800
commit8a58284af6ca62f6b2d88385f4bb3e65a7aa372e (patch)
treee233f49f6c426bbda174c5eacc8107ca3c77d0d1 /graphics/smpeg/Makefile
parente2b8adee9c082e9ca2beaba63a98ae6edad69485 (diff)
downloadfreebsd-ports-gnome-8a58284af6ca62f6b2d88385f4bb3e65a7aa372e.tar.gz
freebsd-ports-gnome-8a58284af6ca62f6b2d88385f4bb3e65a7aa372e.tar.zst
freebsd-ports-gnome-8a58284af6ca62f6b2d88385f4bb3e65a7aa372e.zip
Update to 0.4.2.
Diffstat (limited to 'graphics/smpeg/Makefile')
-rw-r--r--graphics/smpeg/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/graphics/smpeg/Makefile b/graphics/smpeg/Makefile
index 076823110601..f566805f6661 100644
--- a/graphics/smpeg/Makefile
+++ b/graphics/smpeg/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= smpeg
-PORTVERSION= 0.4.0
+PORTVERSION= 0.4.2
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.lokigames.com/pub/open-source/smpeg/ \
ftp://sunsite.auc.dk/pub/os/linux/loki/open-source/smpeg/ \
@@ -22,7 +22,7 @@ SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
USE_GMAKE= yes
USE_GTK= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
GLBASE="${X11BASE}" \
@@ -35,4 +35,8 @@ CONFIGURE_ARGS= --disable-opengl-player \
MAN1= gtv.1 plaympeg.1
+post-configure:
+ @${PERL} -pi -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
+ ${WRKSRC}/libtool
+
.include <bsd.port.mk>