aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/sng/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-03-20 19:47:11 +0800
committerijliao <ijliao@FreeBSD.org>2001-03-20 19:47:11 +0800
commitc752724f768a65812c6d1e737387f81da92fd840 (patch)
tree80988e48629ac5a4e8a8f08ac18ad7a79842cfaf /graphics/sng/Makefile
parentd1d92891c6f7bd9bd4a0afdaf29ec3826e2e317e (diff)
downloadfreebsd-ports-gnome-c752724f768a65812c6d1e737387f81da92fd840.tar.gz
freebsd-ports-gnome-c752724f768a65812c6d1e737387f81da92fd840.tar.zst
freebsd-ports-gnome-c752724f768a65812c6d1e737387f81da92fd840.zip
add sng
The sng program translates between PNG (Portable Network Graphics) format and SNG (Scriptable Network Graphics) format.
Diffstat (limited to 'graphics/sng/Makefile')
-rw-r--r--graphics/sng/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/graphics/sng/Makefile b/graphics/sng/Makefile
new file mode 100644
index 000000000000..ca79dbd09eaa
--- /dev/null
+++ b/graphics/sng/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: sng
+# Date created: Mar 20, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sng
+PORTVERSION= 0.9.4
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-png-inc=${LOCALBASE}/include
+
+USE_GMAKE= yes
+
+MAN1= sng.1
+
+.include <bsd.port.mk>