aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/sng/Makefile
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-04-29 03:27:56 +0800
committerpawel <pawel@FreeBSD.org>2014-04-29 03:27:56 +0800
commit1ae491e4bf4c1a18c9414dca83fdd08252fe3ce3 (patch)
tree8107b4453a40b2e19589f7e26f6fa0de4e866f5f /graphics/sng/Makefile
parent61bcb64ddf9d80ec96f0676e75a721e79fe2ecd6 (diff)
downloadfreebsd-ports-gnome-1ae491e4bf4c1a18c9414dca83fdd08252fe3ce3.tar.gz
freebsd-ports-gnome-1ae491e4bf4c1a18c9414dca83fdd08252fe3ce3.tar.zst
freebsd-ports-gnome-1ae491e4bf4c1a18c9414dca83fdd08252fe3ce3.zip
- Add staging support
- Convert to new LIB_DEPENDS format
Diffstat (limited to 'graphics/sng/Makefile')
-rw-r--r--graphics/sng/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/graphics/sng/Makefile b/graphics/sng/Makefile
index 5c13afcd48fd..bf64dba9e6cd 100644
--- a/graphics/sng/Makefile
+++ b/graphics/sng/Makefile
@@ -12,7 +12,7 @@ COMMENT= Compiler/decompiler for Scriptable Network Graphics
BUILD_DEPENDS= ${LOCALBASE}/lib/X11/rgb.txt:${PORTSDIR}/x11/rgb
RUN_DEPENDS= ${LOCALBASE}/lib/X11/rgb.txt:${PORTSDIR}/x11/rgb
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include/libpng15
@@ -20,15 +20,13 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-png-inc=${LOCALBASE}/include \
--with-rgbtxt=${LOCALBASE}/lib/X11/rgb.txt
-MAN1= sng.1
-PLIST_FILES= bin/sng bin/sng_regress
+PLIST_FILES= bin/sng bin/sng_regress man/man1/sng.1.gz
-NO_STAGE= yes
no-pre-patch:
@${REINPLACE_CMD} -e 's|-static||g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '33,34s|^static ||' ${WRKSRC}/sngd.c
post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/sng_regress ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/sng_regress ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>