aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/sodipodi/files
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-10-01 14:39:34 +0800
committersobomax <sobomax@FreeBSD.org>2001-10-01 14:39:34 +0800
commit2db67752d9e9dbb240ace65503256076a063f32b (patch)
tree94d95e68eb57241ec39a7d624fcada2c8784bf1f /graphics/sodipodi/files
parentfa2485d89c6b6834e40a8f9e1ac3366a2d88a963 (diff)
downloadfreebsd-ports-gnome-2db67752d9e9dbb240ace65503256076a063f32b.tar.gz
freebsd-ports-gnome-2db67752d9e9dbb240ace65503256076a063f32b.tar.zst
freebsd-ports-gnome-2db67752d9e9dbb240ace65503256076a063f32b.zip
Update to 0.24.
Diffstat (limited to 'graphics/sodipodi/files')
-rw-r--r--graphics/sodipodi/files/patch-configure23
-rw-r--r--graphics/sodipodi/files/patch-po::Makefile.in.in32
-rw-r--r--graphics/sodipodi/files/patch-src::sp-text.c14
3 files changed, 69 insertions, 0 deletions
diff --git a/graphics/sodipodi/files/patch-configure b/graphics/sodipodi/files/patch-configure
new file mode 100644
index 000000000000..e57c7d1e01fd
--- /dev/null
+++ b/graphics/sodipodi/files/patch-configure
@@ -0,0 +1,23 @@
+
+$FreeBSD$
+
+--- configure 2001/09/28 13:29:15 1.1
++++ configure 2001/09/28 13:29:37
+@@ -3974,7 +3974,7 @@
+ fi
+
+
+- CATOBJEXT=.gmo
++ CATOBJEXT=.mo
+ fi
+
+ else
+@@ -4096,7 +4096,7 @@
+
+ BUILD_INCLUDED_LIBINTL=yes
+ USE_INCLUDED_LIBINTL=yes
+- CATOBJEXT=.gmo
++ CATOBJEXT=.mo
+ INTLLIBS="\$(top_builddir)/intl/libintl.a $LIBICONV"
+ LIBS=`echo " $LIBS " | sed -e 's/ -lintl / /' -e 's/^ //' -e 's/ $//'`
+ fi
diff --git a/graphics/sodipodi/files/patch-po::Makefile.in.in b/graphics/sodipodi/files/patch-po::Makefile.in.in
new file mode 100644
index 000000000000..b60d540218c1
--- /dev/null
+++ b/graphics/sodipodi/files/patch-po::Makefile.in.in
@@ -0,0 +1,32 @@
+
+$FreeBSD$
+
+--- po/Makefile.in.in 2001/09/28 13:21:12 1.1
++++ po/Makefile.in.in 2001/09/28 13:21:31
+@@ -106,7 +106,7 @@
+ @catalogs='$(CATALOGS)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
++ lang=`echo $$cat | sed 's/\.mo$$//'`; \
+ dir=$(localedir)/$$lang/LC_MESSAGES; \
+ $(mkinstalldirs) $(DESTDIR)$$dir; \
+ if test -r $$cat; then \
+@@ -126,7 +126,7 @@
+ catalogs='$(CATALOGS)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
++ lang=`echo $$cat | sed 's/\.mo$$//'`; \
+ rm -f $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES/$(PACKAGE).mo; \
+ done
+ if test "$(PACKAGE)" = "gettext"; then \
+@@ -172,7 +172,7 @@
+ catalogs='$(GMOFILES)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
++ lang=`echo $$cat | sed 's/\.mo$$//'`; \
+ echo "$$lang:"; \
+ if $(MSGMERGE) $$lang.po $(PACKAGE).pot -o $$lang.new.po; then \
+ mv -f $$lang.new.po $$lang.po; \
diff --git a/graphics/sodipodi/files/patch-src::sp-text.c b/graphics/sodipodi/files/patch-src::sp-text.c
new file mode 100644
index 000000000000..ff27cb0bdf10
--- /dev/null
+++ b/graphics/sodipodi/files/patch-src::sp-text.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/sp-text.c 2001/09/28 13:10:32 1.1
++++ src/sp-text.c 2001/09/28 13:19:21
+@@ -235,7 +235,7 @@
+ x = text->x;
+ y += text->size;
+ } else {
+- g_unichar_to_utf8 (btowc(*c), utfbuf);
++ g_unichar_to_utf8 (*c, utfbuf);
+ glyph = gnome_font_face_lookup_default (face, g_utf8_get_char(utfbuf));
+
+ w = gnome_font_face_get_glyph_width (face, glyph);