aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/springgraph
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-08-07 17:18:53 +0800
committerijliao <ijliao@FreeBSD.org>2002-08-07 17:18:53 +0800
commitf3a5206f22c257f6b2788de17d02511e94d670a6 (patch)
tree7f128968d8346e6585f16a5d6aaa300073599fcf /graphics/springgraph
parent5a1bf24f3fa1317ea508fdecd91900bc403011f6 (diff)
downloadfreebsd-ports-gnome-f3a5206f22c257f6b2788de17d02511e94d670a6.tar.gz
freebsd-ports-gnome-f3a5206f22c257f6b2788de17d02511e94d670a6.tar.zst
freebsd-ports-gnome-f3a5206f22c257f6b2788de17d02511e94d670a6.zip
add springgraph 0.79
Render graph described in a .dot file
Diffstat (limited to 'graphics/springgraph')
-rw-r--r--graphics/springgraph/Makefile33
-rw-r--r--graphics/springgraph/distinfo1
-rw-r--r--graphics/springgraph/pkg-comment1
-rw-r--r--graphics/springgraph/pkg-descr13
-rw-r--r--graphics/springgraph/pkg-plist1
5 files changed, 49 insertions, 0 deletions
diff --git a/graphics/springgraph/Makefile b/graphics/springgraph/Makefile
new file mode 100644
index 000000000000..341b86a812be
--- /dev/null
+++ b/graphics/springgraph/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: springgraph
+# Date created: Aug 8, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= springgraph
+PORTVERSION= 0.79
+CATEGORIES= graphics
+MASTER_SITES= http://www.chaosreigns.com/code/springgraph/dl/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .pl
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
+
+USE_PERL5= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ${WRKDIR}
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e "s|/usr/bin/perl|${PERL}|g" ${WRKSRC}/springgraph.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/springgraph.pl ${PREFIX}/bin/springgraph
+
+.include <bsd.port.mk>
diff --git a/graphics/springgraph/distinfo b/graphics/springgraph/distinfo
new file mode 100644
index 000000000000..ad219a34c374
--- /dev/null
+++ b/graphics/springgraph/distinfo
@@ -0,0 +1 @@
+MD5 (springgraph.pl) = 701e49bbceb35a9054dfc7e55a8c863a
diff --git a/graphics/springgraph/pkg-comment b/graphics/springgraph/pkg-comment
new file mode 100644
index 000000000000..5914aecf2c8f
--- /dev/null
+++ b/graphics/springgraph/pkg-comment
@@ -0,0 +1 @@
+Render graph described in a .dot file
diff --git a/graphics/springgraph/pkg-descr b/graphics/springgraph/pkg-descr
new file mode 100644
index 000000000000..ca48fab5a52f
--- /dev/null
+++ b/graphics/springgraph/pkg-descr
@@ -0,0 +1,13 @@
+Springgraph will read in a .dot file description of a graph, which, for each
+node, specifies its name and which other nodes it is connected to, and then
+renders a graph. Each node is drawn as an ellipse, and each connection is
+drawn as an arrow. The node placement is a result of all of the nodes moving
+away from each other, while all nodes which are connected move toward each
+other. This movement is repeated until it stabilizes.
+
+Springgraph was written as an alternative to neato, which is part of graphviz.
+It attempts to read the same .dot files used by graphviz, but currently only
+supports a limited number of node attributes (label and fillcolor). I am open
+to requests for support for more graph/node/edge attributes.
+
+WWW: http://www.chaosreigns.com/code/springgraph/
diff --git a/graphics/springgraph/pkg-plist b/graphics/springgraph/pkg-plist
new file mode 100644
index 000000000000..facf89bd9178
--- /dev/null
+++ b/graphics/springgraph/pkg-plist
@@ -0,0 +1 @@
+bin/springgraph