aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/squish
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2016-01-13 23:42:39 +0800
committermi <mi@FreeBSD.org>2016-01-13 23:42:39 +0800
commit9acb67cc37de6882ef97b02e69a7e3e605c2bc29 (patch)
tree9606583e452d76b197ac7367da7d6902640cd059 /graphics/squish
parent4f8d8b28c9627bcb6cb1e4e229b49c8bd0ea3ea1 (diff)
downloadfreebsd-ports-gnome-9acb67cc37de6882ef97b02e69a7e3e605c2bc29.tar.gz
freebsd-ports-gnome-9acb67cc37de6882ef97b02e69a7e3e605c2bc29.tar.zst
freebsd-ports-gnome-9acb67cc37de6882ef97b02e69a7e3e605c2bc29.zip
Up until now the port installed only a static version of libsquish
-- because the upstream's makefile only built that. Add our own little makefile, that properly builds both static and shared variants using bsd.lib.mk PR: 206125 Approved by: Reinier de Blois (maintainer)
Diffstat (limited to 'graphics/squish')
-rw-r--r--graphics/squish/Makefile9
-rw-r--r--graphics/squish/files/BSDmakefile15
2 files changed, 20 insertions, 4 deletions
diff --git a/graphics/squish/Makefile b/graphics/squish/Makefile
index 2e63a32328da..77d487dad118 100644
--- a/graphics/squish/Makefile
+++ b/graphics/squish/Makefile
@@ -3,7 +3,7 @@
PORTNAME= squish
PORTVERSION= 1.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://libsquish.googlecode.com/files/
@@ -12,11 +12,12 @@ COMMENT= Open source DXT compression library
LICENSE= MIT
-USES= gmake
+USES= uidfix
MAKE_ENV= INSTALL_DIR=${STAGEDIR}${PREFIX}
PLIST_FILES= include/squish.h \
- lib/libsquish.a
-CXXFLAGS+= -fPIC -include limits.h
+ lib/libsquish.a lib/libsquish.so.1 lib/libsquish.so
+MAKEFILE= ${FILESDIR}/BSDmakefile
+USE_LDCONFIG= yes
OPTIONS_RADIO= RG1
OPTIONS_RADIO_RG1= ALTIVEC SSE
diff --git a/graphics/squish/files/BSDmakefile b/graphics/squish/files/BSDmakefile
new file mode 100644
index 000000000000..cd1235207e66
--- /dev/null
+++ b/graphics/squish/files/BSDmakefile
@@ -0,0 +1,15 @@
+LIB= squish
+SHLIB_MAJOR= 1
+SRCS!= echo *.cpp
+NO_PROFILE= yes
+
+CXXFLAGS+= -include limits.h -I${.CURDIR}
+
+LIBDIR= ${PREFIX}/lib
+INCSDIR= ${PREFIX}/include
+INCS= squish.h
+# The below two are needed until PR 206126 is resolved
+INCSOWN= ${LIBOWN}
+INCSGRP= ${LIBGRP}
+
+.include <bsd.lib.mk>