aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/sswf
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-10-09 00:47:00 +0800
committerpawel <pawel@FreeBSD.org>2013-10-09 00:47:00 +0800
commit84b924a26eac094dfad950943187f5aa7af6cc4c (patch)
treef8a2b1d6d6d53f9049b7cab55cd63fbe5241fccf /graphics/sswf
parentbb84e9819a00c062fcd88a21ac23d8763d125def (diff)
downloadfreebsd-ports-gnome-84b924a26eac094dfad950943187f5aa7af6cc4c.tar.gz
freebsd-ports-gnome-84b924a26eac094dfad950943187f5aa7af6cc4c.tar.zst
freebsd-ports-gnome-84b924a26eac094dfad950943187f5aa7af6cc4c.zip
- Fix build on head with iconv in base
- Remove leading article from COMMENT - Switch to new LIB_DEPENDS, OPTIONS - Add support for STAGEDIR
Diffstat (limited to 'graphics/sswf')
-rw-r--r--graphics/sswf/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/graphics/sswf/Makefile b/graphics/sswf/Makefile
index c74c35f4c6ae..0dec0bf858f4 100644
--- a/graphics/sswf/Makefile
+++ b/graphics/sswf/Makefile
@@ -9,10 +9,10 @@ MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
-COMMENT= A library and script language tool to create Flash movies
+COMMENT= Library and script language tool to create Flash movies
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libfreetype.so:${PORTSDIR}/print/freetype2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -26,9 +26,17 @@ PLIST_SUB= VERSION="${PORTVERSION}"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if !defined(WITH_DEBUG)
+OPTIONS_DEFINE= DEBUG
+
+.include <bsd.port.options.mk>
+
+.if ! ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --disable-debug --disable-yydebug
.endif
-NO_STAGE= yes
+post-configure:
+ @${REINPLACE_CMD} 's|ICONV_INPUT_CAST||' \
+ ${WRKSRC}/src/lib/libsswf_tag_header.c++ \
+ ${WRKSRC}/src/sswf/sswf_lexical.c++
+
.include <bsd.port.mk>