aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/svgalib/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-08-31 01:41:08 +0800
committersobomax <sobomax@FreeBSD.org>2000-08-31 01:41:08 +0800
commitef51e392656405db6a7131b7f9e9f4f8322db8c0 (patch)
treec3bd889cd4bf1c84e1887f1183e91f79c792ec57 /graphics/svgalib/Makefile
parentc21da218e9c3db84dd608a1141b8894821ef6cda (diff)
downloadfreebsd-ports-gnome-ef51e392656405db6a7131b7f9e9f4f8322db8c0.tar.gz
freebsd-ports-gnome-ef51e392656405db6a7131b7f9e9f4f8322db8c0.tar.zst
freebsd-ports-gnome-ef51e392656405db6a7131b7f9e9f4f8322db8c0.zip
Improve FreeBSD support:
+ properly handle keyboard input; + enable linear modes (required for SDL); - still no mouse yet.
Diffstat (limited to 'graphics/svgalib/Makefile')
-rw-r--r--graphics/svgalib/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/graphics/svgalib/Makefile b/graphics/svgalib/Makefile
index 91178218ef19..d1faff83f7ca 100644
--- a/graphics/svgalib/Makefile
+++ b/graphics/svgalib/Makefile
@@ -14,8 +14,9 @@ MAINTAINER= sobomax@freebsd.org
USE_GMAKE= yes
INSTALLS_SHLIB= yes
+CFLAGS+= -DDEBUG
-ALL_TARGET= shared
+ALL_TARGET= shared static
MAN1= convfont.1 dumpreg.1 fix132x43.1 restorefont.1 \
restorepalette.1 restoretextmode.1 runx.1 \
@@ -107,5 +108,11 @@ MAN8= mode3.8
pre-patch:
${PERL} -pi -e 's.\x0D..' ${WRKSRC}/utils/gtf/*
+ ${MKDIR} ${WRKSRC}/include/linux
+
+post-install:
+ ${MKDIR} ${PREFIX}/include/linux
+ cd ${WRKSRC}/include/linux && \
+ ${INSTALL_DATA} keyboard.h kd.h ${PREFIX}/include/linux
.include <bsd.port.mk>