aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/swfdec
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2005-02-22 18:12:32 +0800
committerkwm <kwm@FreeBSD.org>2005-02-22 18:12:32 +0800
commit6bc5e6592c698928614c637550ee157f396d2e23 (patch)
treed3aebd47b1b284b0ff4b0192a4c950e18c851e98 /graphics/swfdec
parent6799224d1ec025e6c092b1a23c0b391b7aac573f (diff)
downloadfreebsd-ports-gnome-6bc5e6592c698928614c637550ee157f396d2e23.tar.gz
freebsd-ports-gnome-6bc5e6592c698928614c637550ee157f396d2e23.tar.zst
freebsd-ports-gnome-6bc5e6592c698928614c637550ee157f396d2e23.zip
Correct gimp lib name.
Only create gimp plugin dir when compiling gimp support [1]. Extra large pointyhat for me. Submitted by: [1] Pointyhat
Diffstat (limited to 'graphics/swfdec')
-rw-r--r--graphics/swfdec/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/graphics/swfdec/Makefile b/graphics/swfdec/Makefile
index 4b610a7619a9..981ef486457b 100644
--- a/graphics/swfdec/Makefile
+++ b/graphics/swfdec/Makefile
@@ -8,7 +8,7 @@
PORTNAME= swfdec
PORTVERSION= 0.3.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://www.schleef.org/swfdec/download/
@@ -31,8 +31,12 @@ INSTALLS_SHLIB= yes
PLIST_SUB= VERSION=${PORTVERSION:R}
-.if exists(${X11BASE}/bin/gimp-2.2) || defined(WITH_GIMP)
-LIB_DEPENDS+= gimp.200:${PORTSDIR}/graphics/gimp
+.if exists(${X11BASE}/bin/gimp-2.2)
+WITH_GIMP=yes
+.endif
+
+.if defined(WITH_GIMP)
+LIB_DEPENDS+= gimp-2.0.200:${PORTSDIR}/graphics/gimp
PLIST_SUB+= GIMP=""
.else
PLIST_SUB+= GIMP="@comment "
@@ -44,6 +48,9 @@ pre-everything::
@${ECHO} ""
post-patch:
+.if !defined(WITH_GIMP)
+ @${REINPLACE_CMD} -e 's|gimp-loader||g' ${WRKSRC}/Makefile.in
+.endif
@${REINPLACE_CMD} -e "s,int16_t,__int16_t," ${WRKSRC}/libswfdec/swfdec_shape.c
@${REINPLACE_CMD} -e 's|libdir)/gimp/1.3|prefix)/libexec/gimp/2.2|g' ${WRKSRC}/gimp-loader/Makefile.in
@${REINPLACE_CMD} -e 's|plugin||g' ${WRKSRC}/Makefile.in