aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/swfdec
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2003-05-19 08:14:18 +0800
committerpetef <petef@FreeBSD.org>2003-05-19 08:14:18 +0800
commitd0f6863181f92caf90ccb098abde01da3fae06b4 (patch)
tree4b624b8fa28945b729bb3dc5070c3b57faf5da49 /graphics/swfdec
parentfed5d9ccbb045cfb3235b241c9f3ce7336d5f87a (diff)
downloadfreebsd-ports-gnome-d0f6863181f92caf90ccb098abde01da3fae06b4.tar.gz
freebsd-ports-gnome-d0f6863181f92caf90ccb098abde01da3fae06b4.tar.zst
freebsd-ports-gnome-d0f6863181f92caf90ccb098abde01da3fae06b4.zip
- install .pc file to the correct place
- use USE_GETOPT_LONG - sort pkg-plist correctly - bump PORTREVISION PR: 52136 Submitted by: Ports Fury
Diffstat (limited to 'graphics/swfdec')
-rw-r--r--graphics/swfdec/Makefile18
-rw-r--r--graphics/swfdec/files/patch-ltmain.sh23
-rw-r--r--graphics/swfdec/pkg-plist4
3 files changed, 17 insertions, 28 deletions
diff --git a/graphics/swfdec/Makefile b/graphics/swfdec/Makefile
index 284dc2840852..48ea71394da2 100644
--- a/graphics/swfdec/Makefile
+++ b/graphics/swfdec/Makefile
@@ -8,6 +8,7 @@
PORTNAME= swfdec
PORTVERSION= 0.2.1
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,19 +16,24 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Flash Rendering Library
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
- mad.1:${PORTSDIR}/audio/mad \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+ mad.1:${PORTSDIR}/audio/mad
+RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_X_PREFIX= yes
+USE_GNOME= gnomehack gtk20 libartlgpl2
+USE_GETOPT_LONG= yes
USE_REINPLACE= yes
-USE_GNOME= gtk20 libartlgpl2
-SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} LDFLAGS="{LDFLAGS}
INSTALLS_SHLIB= yes
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
post-patch:
@${REINPLACE_CMD} -e "s|sdl-config|${SDL_CONFIG}|" ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|malloc\.h|stdlib.h|" ${WRKSRC}/libswfdec/jpeg/sl_types.h
diff --git a/graphics/swfdec/files/patch-ltmain.sh b/graphics/swfdec/files/patch-ltmain.sh
index e6e5cf7c8c62..af1fdc325897 100644
--- a/graphics/swfdec/files/patch-ltmain.sh
+++ b/graphics/swfdec/files/patch-ltmain.sh
@@ -1,14 +1,6 @@
---- ltmain.sh.orig Sun Apr 6 15:09:32 2003
-+++ ltmain.sh Sun Apr 6 15:09:58 2003
-@@ -1065,14 +1065,14 @@
- # These systems don't actually have a C library (as such)
- test "X$arg" = "X-lc" && continue
- ;;
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd*)
- # Do not include libc due to us having libc/libc_r.
- test "X$arg" = "X-lc" && continue
- ;;
+--- ltmain.sh.orig Thu Feb 6 05:37:40 2003
++++ ltmain.sh Tue May 13 06:48:33 2003
+@@ -1072,7 +1072,7 @@
esac
elif test "X$arg" = "X-lc_r"; then
case $host in
@@ -17,15 +9,6 @@
# Do not include libc_r directly, use -pthread flag.
continue
;;
-@@ -2495,7 +2495,7 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd*)
- # Do not include libc due to us having libc/libc_r.
- ;;
- *)
@@ -4325,10 +4325,12 @@
fi
diff --git a/graphics/swfdec/pkg-plist b/graphics/swfdec/pkg-plist
index ab8c3ee0b67c..7a0976b591f7 100644
--- a/graphics/swfdec/pkg-plist
+++ b/graphics/swfdec/pkg-plist
@@ -1,10 +1,10 @@
bin/swf_play
include/swfdec/swf.h
include/swfdec/swfdec.h
-@dirrm include/swfdec
lib/gtk-2.0/2.2.0/loaders/swf_loader.a
lib/gtk-2.0/2.2.0/loaders/swf_loader.so
lib/libswfdec.a
lib/libswfdec.so
lib/libswfdec.so.0
-lib/pkgconfig/swfdec.pc
+libdata/pkgconfig/swfdec.pc
+@dirrm include/swfdec