aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/synaesthesia/Makefile
diff options
context:
space:
mode:
authorgreid <greid@FreeBSD.org>2001-05-26 18:48:21 +0800
committergreid <greid@FreeBSD.org>2001-05-26 18:48:21 +0800
commitc440c8e3793426ad2f9f4327596238a82c309a65 (patch)
treea87c54d9df7dbc37f5ed1b8da3637b6f4ef13881 /graphics/synaesthesia/Makefile
parent6592e363f2280c39d0fcc4a51de1a13cac81adf1 (diff)
downloadfreebsd-ports-gnome-c440c8e3793426ad2f9f4327596238a82c309a65.tar.gz
freebsd-ports-gnome-c440c8e3793426ad2f9f4327596238a82c309a65.tar.zst
freebsd-ports-gnome-c440c8e3793426ad2f9f4327596238a82c309a65.zip
Add synaesthesia 2.1, a program to graphically represents sound in real
time PR: 27652 Submitted by: Pete Fritchman <petef@databits.net>
Diffstat (limited to 'graphics/synaesthesia/Makefile')
-rw-r--r--graphics/synaesthesia/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/graphics/synaesthesia/Makefile b/graphics/synaesthesia/Makefile
new file mode 100644
index 000000000000..5a1b24358a12
--- /dev/null
+++ b/graphics/synaesthesia/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: synaesthesia
+# Date created: 25 May 2001
+# Whom: petef@databits.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= synaesthesia
+PORTVERSION= 2.1
+CATEGORIES= graphics
+MASTER_SITES= http://yoyo.cc.monash.edu.au/~pfh/
+
+MAINTAINER= petef@databits.net
+
+LIB_DEPENDS= SDL-1.0.2:${PORTSDIR}/devel/sdl10
+
+USE_GMAKE= Yes
+USE_X_PREFIX= Yes
+
+GNU_CONFIGURE= Yes
+CONFIGURE_ARGS= --with-sdl-prefix=${LOCALBASE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/synaesthesia ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/synaesthesia
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/synaesthesia
+.endif
+
+.include <bsd.port.mk>