aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/tcm/Makefile
diff options
context:
space:
mode:
authormich <mich@FreeBSD.org>2004-08-18 23:59:36 +0800
committermich <mich@FreeBSD.org>2004-08-18 23:59:36 +0800
commitf9f17e9dbded41712b7cd080c8d19e2de1d4d542 (patch)
treecddb7f90f031ec51c412cd93012e30b1311c8030 /graphics/tcm/Makefile
parent7734b09f120c8b32b2233460a84c362bf461d717 (diff)
downloadfreebsd-ports-gnome-f9f17e9dbded41712b7cd080c8d19e2de1d4d542.tar.gz
freebsd-ports-gnome-f9f17e9dbded41712b7cd080c8d19e2de1d4d542.tar.zst
freebsd-ports-gnome-f9f17e9dbded41712b7cd080c8d19e2de1d4d542.zip
o Fix build with gcc 3.4.x
o Switch to REINPLACE_CMD o Tested on CURRENT-amd64 / CURRENT-i386 / 5.2.1REL-i386 Tested by mux
Diffstat (limited to 'graphics/tcm/Makefile')
-rw-r--r--graphics/tcm/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/graphics/tcm/Makefile b/graphics/tcm/Makefile
index 1ede5462e57d..dc1b4e9e5b42 100644
--- a/graphics/tcm/Makefile
+++ b/graphics/tcm/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= fig2dev:${PORTSDIR}/print/transfig
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_REINPLACE= yes
USE_MOTIF= yes
USE_BISON= yes
USE_GMAKE= yes
@@ -33,8 +34,9 @@ MAN1= psf.1 tatd.1 tcbd.1 tcm.1 tcmd.1 tcmdv.1 tcmt.1 tcpd.1 tcrd.1 \
post-patch:
@${RM} ${WRKSRC}/man/windex
@${CHMOD} 0644 ${WRKSRC}/lib/colorrgb.txt
+ @${REINPLACE_CMD} -e 's:gcc:g++:g' ${WRKSRC}/bin/makedepend.sh
post-install:
- @${SED} -e 's:/usr/local:${PREFIX}:g' ${PKGMESSAGE}
+ @${REINPLACE_CMD} -e 's:/usr/local:${PREFIX}:g' ${PKGMESSAGE}
.include <bsd.port.mk>