aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/tif22pnm
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2012-11-27 20:22:40 +0800
committermartymac <martymac@FreeBSD.org>2012-11-27 20:22:40 +0800
commitbdbdafc1a5c741fa6421c50ad7c20c7c5ddd1a3e (patch)
treee9f78c8e01a00d9cad59afec1ef9801ca512f8d5 /graphics/tif22pnm
parentd11effe6ca67f823279d106e39c18d8c45172825 (diff)
downloadfreebsd-ports-gnome-bdbdafc1a5c741fa6421c50ad7c20c7c5ddd1a3e.tar.gz
freebsd-ports-gnome-bdbdafc1a5c741fa6421c50ad7c20c7c5ddd1a3e.tar.zst
freebsd-ports-gnome-bdbdafc1a5c741fa6421c50ad7c20c7c5ddd1a3e.zip
Update to 0.14
Feature safe: yes
Diffstat (limited to 'graphics/tif22pnm')
-rw-r--r--graphics/tif22pnm/Makefile3
-rw-r--r--graphics/tif22pnm/distinfo4
-rw-r--r--graphics/tif22pnm/files/patch-png22pnm.c59
3 files changed, 3 insertions, 63 deletions
diff --git a/graphics/tif22pnm/Makefile b/graphics/tif22pnm/Makefile
index d5db23a6d8a0..e9ef65a5846c 100644
--- a/graphics/tif22pnm/Makefile
+++ b/graphics/tif22pnm/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= tif22pnm
-PORTVERSION= 0.12
-PORTREVISION= 7
+PORTVERSION= 0.14
CATEGORIES= graphics
MASTER_SITES= http://pts.szit.bme.hu/ \
GOOGLE_CODE
diff --git a/graphics/tif22pnm/distinfo b/graphics/tif22pnm/distinfo
index ebdda243c333..0061c291dbc0 100644
--- a/graphics/tif22pnm/distinfo
+++ b/graphics/tif22pnm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tif22pnm-0.12.tar.gz) = 4253f27d5578aeae8f88e75f41a205da8d2dc466d1efff39a3667a9ff55fb73a
-SIZE (tif22pnm-0.12.tar.gz) = 107684
+SHA256 (tif22pnm-0.14.tar.gz) = d59ea3f1fdd6802e66a44fbfa8979d4e61c9fd021de36675249a877392378e01
+SIZE (tif22pnm-0.14.tar.gz) = 108047
diff --git a/graphics/tif22pnm/files/patch-png22pnm.c b/graphics/tif22pnm/files/patch-png22pnm.c
deleted file mode 100644
index 45212e6231ec..000000000000
--- a/graphics/tif22pnm/files/patch-png22pnm.c
+++ /dev/null
@@ -1,59 +0,0 @@
---- png22pnm.c.orig 2003-03-18 17:14:51.000000000 +0100
-+++ png22pnm.c 2012-05-04 07:36:40.000000000 +0200
-@@ -40,6 +40,7 @@
-
- #include <math.h>
- #include <png.h> /* includes zlib.h and setjmp.h */
-+#include <pngpriv.h>
- #if 0
- #define VERSION "p2.37.4 (5 December 1999) +netpbm"
- #else
-@@ -783,7 +784,7 @@
- (info_ptr->valid & PNG_INFO_tRNS)) {
- trans_mix = TRUE;
- for (i = 0 ; i < info_ptr->num_trans ; i++)
-- if (info_ptr->trans[i] != 0 && info_ptr->trans[i] != 255) {
-+ if (info_ptr->trans_alpha[i] != 0 && info_ptr->trans_alpha[i] != 255) {
- trans_mix = FALSE;
- break;
- }
-@@ -932,7 +933,7 @@
- pnm_type = PBM_TYPE;
- if (info_ptr->valid & PNG_INFO_tRNS) {
- for (i = 0 ; i < info_ptr->num_trans ; i++) {
-- if (info_ptr->trans[i] != 0 && info_ptr->trans[i] != maxval) {
-+ if (info_ptr->trans_alpha[i] != 0 && info_ptr->trans_alpha[i] != maxval) {
- pnm_type = PGM_TYPE;
- break;
- }
-@@ -1009,7 +1010,7 @@
- case PNG_COLOR_TYPE_GRAY:
- store_pixel (pnm_pixel, c, c, c,
- ((info_ptr->valid & PNG_INFO_tRNS) &&
-- (c == gamma_correct (info_ptr->trans_values.gray, totalgamma))) ?
-+ (c == gamma_correct (info_ptr->trans_color.gray, totalgamma))) ?
- 0 : maxval);
- break;
-
-@@ -1023,7 +1024,7 @@
- info_ptr->palette[c].green, info_ptr->palette[c].blue,
- (info_ptr->valid & PNG_INFO_tRNS) &&
- c<info_ptr->num_trans ?
-- info_ptr->trans[c] : maxval);
-+ info_ptr->trans_alpha[c] : maxval);
- break;
-
- case PNG_COLOR_TYPE_RGB:
-@@ -1031,9 +1032,9 @@
- c3 = get_png_val (png_pixel);
- store_pixel (pnm_pixel, c, c2, c3,
- ((info_ptr->valid & PNG_INFO_tRNS) &&
-- (c == gamma_correct (info_ptr->trans_values.red, totalgamma)) &&
-- (c2 == gamma_correct (info_ptr->trans_values.green, totalgamma)) &&
-- (c3 == gamma_correct (info_ptr->trans_values.blue, totalgamma))) ?
-+ (c == gamma_correct (info_ptr->trans_color.red, totalgamma)) &&
-+ (c2 == gamma_correct (info_ptr->trans_color.green, totalgamma)) &&
-+ (c3 == gamma_correct (info_ptr->trans_color.blue, totalgamma))) ?
- 0 : maxval);
- break;
-