aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/tiff/Makefile
diff options
context:
space:
mode:
authormax <max@FreeBSD.org>1997-01-09 18:48:53 +0800
committermax <max@FreeBSD.org>1997-01-09 18:48:53 +0800
commit68c02db76ffb92af7f85f79031c4bad4df57caaf (patch)
tree919d0261e7655358ddf5c9d90f901230c6c7ac1d /graphics/tiff/Makefile
parentde931f62eb3c9e25fd3cde3ab65ebe10e868099f (diff)
downloadfreebsd-ports-gnome-68c02db76ffb92af7f85f79031c4bad4df57caaf.tar.gz
freebsd-ports-gnome-68c02db76ffb92af7f85f79031c4bad4df57caaf.tar.zst
freebsd-ports-gnome-68c02db76ffb92af7f85f79031c4bad4df57caaf.zip
Port of TIFF 3.4. This port was originally submitted by Richard Hwang
<rhwang@bigpanda.com> and Mikhail Teterin <mi@aldan.ziplink.net>. Thomas Gellekum <thomas@ghpc8.ihf.rwth-aachen.de> and I merged these ports and modified it. TIFF 3.4 does not seem to be completely compatible with tiff 3.3, so we decided to make separate port for this version. Special thanks goes to tg, for reviewing and intensively testing. (Closing PR #2057.)
Diffstat (limited to 'graphics/tiff/Makefile')
-rw-r--r--graphics/tiff/Makefile67
1 files changed, 67 insertions, 0 deletions
diff --git a/graphics/tiff/Makefile b/graphics/tiff/Makefile
new file mode 100644
index 000000000000..2cdd45f6d743
--- /dev/null
+++ b/graphics/tiff/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: tiff34
+# Version required: 3.4beta035
+# Date created: 8 October 1996
+# Whom: Richard Hwang <rhwang@bigpanda.com>
+# Mikhail Teterin <mi@aldan.ziplink.net>
+#
+# $Id$
+#
+
+DISTNAME= tiff-v3.4beta035
+PKGNAME= tiff-3.4b035
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.sgi.com/graphics/tiff/ \
+ ftp://ftp.isri.unlv.edu/pub/mirror/tiff/
+EXTRACT_SUFX= -tar.gz
+
+LIB_DEPENDS= jpeg\\.7\\.:${PORTSDIR}/graphics/jpeg
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --with-ZIP --with-JPEG --with-DIR_BIN=${PREFIX}/bin \
+ --with-DIR_LIB=${PREFIX}/lib --with-DIR_INC=${PREFIX}/include \
+ --with-CC="${CC}" --with-GCOPTS="${CFLAGS}" \
+ --with-DIRS_LIBINC=${PREFIX}/include \
+ --with-DIR_GZLIB=/usr/lib \
+ --with-DIR_JPEGLIB=${PREFIX}/lib \
+ --with-LIBGL=no --with-LIBIMAGE=no \
+ --with-INSTALL="/bin/sh ${WRKSRC}/port/install.sh" \
+ --noninteractive
+MAN1= fax2ps.1 fax2tiff.1 gif2tiff.1 pal2rgb.1 ppm2tiff.1 ras2tiff.1 \
+ rgb2ycbcr.1 sgi2tiff.1 thumbnail.1 tiff2bw.1 tiff2ps.1 tiffcmp.1 \
+ tiffcp.1 tiffdither.1 tiffdump.1 tiffgt.1 tiffinfo.1 tiffmedian.1 \
+ tiffsplit.1 tiffsv.1
+MAN3= TIFFCheckTile.3t TIFFClose.3t TIFFComputeStrip.3t TIFFComputeTile.3t \
+ TIFFCurrentDirectory.3t TIFFCurrentRow.3t TIFFCurrentStrip.3t \
+ TIFFCurrentTile.3t TIFFDefaultStripSize.3t TIFFDefaultTileSize.3t \
+ TIFFError.3t TIFFFdOpen.3t TIFFFileName.3t TIFFFileno.3t \
+ TIFFFindCODEC.3t TIFFFlush.3t TIFFFlushData.3t TIFFGetField.3t \
+ TIFFGetMode.3t TIFFIsByteSwapped.3t TIFFIsMSB2LSB.3t TIFFIsTiled.3t \
+ TIFFIsUpSampled.3t TIFFLastDirectory.3t TIFFNumberOfStrips.3t \
+ TIFFNumberOfTiles.3t TIFFOpen.3t TIFFPrintDirectory.3t \
+ TIFFRGBAImage.3t TIFFRGBAImageBegin.3t TIFFRGBAImageEnd.3t \
+ TIFFRGBAImageGet.3t TIFFRGBAImageOK.3t TIFFReadBufferSetup.3t \
+ TIFFReadDirectory.3t TIFFReadEncodedStrip.3t TIFFReadEncodedTile.3t \
+ TIFFReadRGBAImage.3t TIFFReadRawStrip.3t TIFFReadRawTile.3t \
+ TIFFReadScanline.3t TIFFReadTile.3t TIFFRegisterCODEC.3t \
+ TIFFReverseBits.3t TIFFScanlineSize.3t TIFFSetDirectory.3t \
+ TIFFSetErrorHandler.3t TIFFSetField.3t TIFFSetSubDirectory.3t \
+ TIFFSetWarningHandler.3t TIFFStripSize.3t TIFFSwabArrayOfLong.3t \
+ TIFFSwabArrayOfShort.3t TIFFSwabLong.3t TIFFSwabShort.3t \
+ TIFFTileRowSize.3t TIFFTileSize.3t TIFFUnRegisterCODEC.3t \
+ TIFFVGetField.3t TIFFVSetField.3t TIFFVStripSize.3t TIFFVTileSize.3t \
+ TIFFWarning.3t TIFFWriteBufferSetup.3t TIFFWriteDirectory.3t \
+ TIFFWriteEncodedStrip.3t TIFFWriteEncodedTile.3t TIFFWriteRawStrip.3t \
+ TIFFWriteRawTile.3t TIFFWriteScanline.3t TIFFbuffer.3t TIFFcodec.3t \
+ TIFFfree.3t TIFFmalloc.3t TIFFmemcmp.3t TIFFmemcpy.3t TIFFmemory.3t \
+ TIFFmemset.3t TIFFquery.3t TIFFrealloc.3t TIFFsize.3t TIFFstrip.3t \
+ TIFFswab.3t TIFFtile.3t libtiff.3t
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/tiff/images
+ ${INSTALL_DATA} ${WRKSRC}/html/*.html ${PREFIX}/share/doc/tiff
+ ${INSTALL_DATA} ${WRKSRC}/html/images/* ${PREFIX}/share/doc/tiff/images
+.endif
+ /sbin/ldconfig -m ${PREFIX}/lib
+
+.include <bsd.port.mk>