aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/tiff
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2005-01-05 04:59:26 +0800
committerdinoex <dinoex@FreeBSD.org>2005-01-05 04:59:26 +0800
commit1128cfeb953a4e33bc794e5741e99b50e028a417 (patch)
tree23cce7a65b152e90bfda9eee752fc8f23ea6104d /graphics/tiff
parent5987499d1bd0ead8a23258cb74e889fed143080c (diff)
downloadfreebsd-ports-gnome-1128cfeb953a4e33bc794e5741e99b50e028a417.tar.gz
freebsd-ports-gnome-1128cfeb953a4e33bc794e5741e99b50e028a417.tar.zst
freebsd-ports-gnome-1128cfeb953a4e33bc794e5741e99b50e028a417.zip
- add patch for transparent tiff images
http://bugzilla.remotesensing.org/show_bug.cgi?id=718 Submitted by: Dierk Sacher Approved by: portmgr (krion)
Diffstat (limited to 'graphics/tiff')
-rw-r--r--graphics/tiff/Makefile1
-rw-r--r--graphics/tiff/files/patch-tif_getimage.c12
2 files changed, 13 insertions, 0 deletions
diff --git a/graphics/tiff/Makefile b/graphics/tiff/Makefile
index 4f4f762b3550..722974191964 100644
--- a/graphics/tiff/Makefile
+++ b/graphics/tiff/Makefile
@@ -9,6 +9,7 @@
PORTNAME= tiff
PORTVERSION= 3.7.1
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.remotesensing.org/pub/libtiff/ \
http://dl1.maptools.org/dl/libtiff/
diff --git a/graphics/tiff/files/patch-tif_getimage.c b/graphics/tiff/files/patch-tif_getimage.c
new file mode 100644
index 000000000000..2e19f67fb47a
--- /dev/null
+++ b/graphics/tiff/files/patch-tif_getimage.c
@@ -0,0 +1,12 @@
+diff -u -p -r1.43 libtiff/tif_getimage.c
+--- libtiff/tif_getimage.c 19 Dec 2004 17:11:17 -0000 1.43
++++ libtiff/tif_getimage.c 24 Dec 2004 09:30:18 -0000
+@@ -247,7 +247,7 @@ TIFFRGBAImageBegin(TIFFRGBAImage* img, T
+ TIFFGetFieldDefaulted(tif, TIFFTAG_SAMPLESPERPIXEL, &img->samplesperpixel);
+ TIFFGetFieldDefaulted(tif, TIFFTAG_EXTRASAMPLES,
+ &extrasamples, &sampleinfo);
+- if (extrasamples > 1)
++ if (extrasamples >= 1)
+ {
+ switch (sampleinfo[0]) {
+ case EXTRASAMPLE_UNSPECIFIED: /* Workaround for some images without */