aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/tiff
diff options
context:
space:
mode:
authorjedgar <jedgar@FreeBSD.org>2000-01-24 04:44:27 +0800
committerjedgar <jedgar@FreeBSD.org>2000-01-24 04:44:27 +0800
commit68257f478d9a1540768f490115f8d2a2094b06dd (patch)
tree4f01d630ea2b026a5a4d26d8d079af6b576ffa99 /graphics/tiff
parent8c0e53bc386015690aa9b1600cef5a7ce0cce347 (diff)
downloadfreebsd-ports-gnome-68257f478d9a1540768f490115f8d2a2094b06dd.tar.gz
freebsd-ports-gnome-68257f478d9a1540768f490115f8d2a2094b06dd.tar.zst
freebsd-ports-gnome-68257f478d9a1540768f490115f8d2a2094b06dd.zip
Fix port to not create a rogue /tiff.sw.tools directory
during installation PR: 16079 Submitted by: Maxim Sobolev <sobomax@altavista.net>
Diffstat (limited to 'graphics/tiff')
-rw-r--r--graphics/tiff/files/patch-ac31
1 files changed, 25 insertions, 6 deletions
diff --git a/graphics/tiff/files/patch-ac b/graphics/tiff/files/patch-ac
index 8b7f6309a316..c4770573bf9a 100644
--- a/graphics/tiff/files/patch-ac
+++ b/graphics/tiff/files/patch-ac
@@ -1,14 +1,33 @@
---- tools/Makefile.in.orig Tue Sep 2 13:54:34 1997
-+++ tools/Makefile.in Sat Jan 23 10:44:45 1999
-@@ -46 +46 @@
+--- tools/Makefile.in.orig Mon Dec 20 18:46:11 1999
++++ tools/Makefile.in Sun Jan 23 15:39:20 2000
+@@ -43,17 +43,17 @@
+ INSTALL = @INSTALL@
+ #
+ COPTS = @GCOPTS@
-OPTIMIZER=-O
+#OPTIMIZER=-O
-@@ -48 +48 @@
+ IPATH = -I. -I${SRCDIR} -I${LIBDIR}
-CFLAGS = @ENVOPTS@ ${COPTS} ${OPTIMIZER} ${IPATH}
+CFLAGS = @ENVOPTS@ ${COPTS} ${OPTIMIZER} ${IPATH} -L../libtiff
-@@ -50 +50 @@
+ #
-TIFFLIB = ${DEPTH}/libtiff/libtiff.@DSOSUF@
+TIFFLIB = ${DEPTH}/libtiff/libtiff.@DSOSUF_VERSION@
-@@ -56 +56 @@
+ LIBJPEG = @LIBJPEG@
+ LIBGZ = @LIBGZ@
+ LIBTIFF = @TIFFLIBREF@
+ LIBPORT = @LIBPORT@
+ MACHLIBS= @MACHDEPLIBS@
-LIBS = ${LIBTIFF} ${LIBJPEG} ${LIBGZ} ${LIBPORT} ${MACHLIBS}
+LIBS = ${LIBJPEG} ${LIBGZ} ${LIBPORT} ${MACHLIBS} -ltiff
+ #
+ OBJS= \
+ fax2tiff.o \
+@@ -108,7 +108,7 @@
+ true; \
+ fi
+ install: all
+- ${INSTALL} -idb nostrip tiff.sw.tools -m 755 -dir @DIR_BIN@
++ ${INSTALL} -idb tiff.sw.tools -m 755 -dir @DIR_BIN@
+ ${INSTALL} -idb nostrip tiff.sw.tools -m 755 -F @DIR_BIN@ -O ${TARGETS}
+ @if [ "@LIBIMAGE@" = yes ]; then \
+ ${INSTALL} -idb tiff.sw.tools -m 755 -F @DIR_BIN@ -O sgi2tiff; \